summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-03-30 16:42:46 +0200
committerRemi Collet <remi@remirepo.net>2020-03-30 16:42:46 +0200
commitfb719003943a81f5b8ffbda671f772aac717fcf0 (patch)
tree27f53bdd39cb17a69d236959344293288b888530
parent791eb72e0fc5ea987f89e8def58c5adb91342a9b (diff)
add patch for PEAR and PHP 7.4 from
https://github.com/pear/pear-core/pull/103
-rw-r--r--103.patch25
-rw-r--r--php-pear.spec8
2 files changed, 32 insertions, 1 deletions
diff --git a/103.patch b/103.patch
new file mode 100644
index 0000000..c5e9666
--- /dev/null
+++ b/103.patch
@@ -0,0 +1,25 @@
+From 76e3fae5072624639045a15fbe88d22e198ad649 Mon Sep 17 00:00:00 2001
+From: Damon <damon.tu@outlook.com>
+Date: Fri, 29 Nov 2019 10:44:05 +0800
+Subject: [PATCH] Fix undefined constant name
+
+---
+ PEAR/Builder.php | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/PEAR/Builder.php b/PEAR/Builder.php
+index a7b464341..bfc2ca221 100644
+--- a/PEAR/Builder.php
++++ b/PEAR/Builder.php
+@@ -402,9 +402,9 @@ function build($descfile, $callback = null)
+ }
+ if (substr($option['name'], 0, 5) === 'with-' &&
+ ($response === 'yes' || $response === 'autodetect')) {
+- $configure_command .= " --{$option[name]}";
++ $configure_command .= " --{$option['name']}";
+ } else {
+- $configure_command .= " --{$option[name]}=".trim($response);
++ $configure_command .= " --{$option['name']}=".trim($response);
+ }
+ }
+ }
diff --git a/php-pear.spec b/php-pear.spec
index e8e0424..b3e4f3e 100644
--- a/php-pear.spec
+++ b/php-pear.spec
@@ -40,7 +40,7 @@
Summary: PHP Extension and Application Repository framework
Name: %{?scl_prefix}php-pear
Version: 1.10.10
-Release: 5%{?dist}
+Release: 7%{?dist}
Epoch: 1
# PEAR, PEAR_Manpages, Archive_Tar, XML_Util, Console_Getopt are BSD
# Structures_Graph is LGPLv3+
@@ -62,6 +62,7 @@ Source24: http://pear.php.net/get/XML_Util-%{xmlutil}.tgz
Source25: http://pear.php.net/get/PEAR_Manpages-%{manpages}.tgz
Patch0: https://patch-diff.githubusercontent.com/raw/pear/XML_Util/pull/12.patch
+Patch1: https://patch-diff.githubusercontent.com/raw/pear/pear-core/pull/103.patch
BuildArch: noarch
BuildRequires: %{?scl_prefix}php(language) > 5.4
@@ -280,6 +281,7 @@ install -m 644 -D macros.pear \
# apply patches on installed PEAR tree
pushd %{buildroot}%{peardir}
patch -p1 < %{PATCH0}
+patch -p1 < %{PATCH1}
popd
# Why this file here ?
@@ -464,6 +466,10 @@ fi
%changelog
+* Mon Mar 30 2020 Remi Collet <remi@remirepo.net> - 1:1.10.10-7
+- add patch for PEAR and PHP 7.4 from
+ https://github.com/pear/pear-core/pull/103
+
* Thu Dec 12 2019 Remi Collet <remi@remirepo.net> - 1:1.10.10-5
- add patch for XML_Util and PHP 7.4 from
https://github.com/pear/XML_Util/pull/12