summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-07-26 10:23:32 +0200
committerRemi Collet <fedora@famillecollet.com>2015-07-26 10:23:32 +0200
commitdb523b0405a01bb960aaec61c2aba7e976c7c964 (patch)
tree6dfa8c692889eebe4ee4aaadc4d58a6f166220b6
parentfac0638d1f1a637f2844f267d3b4b05c240b44b7 (diff)
php-pear: minor fix for packaging
-rw-r--r--php-pear-1.10-metadata.patch24
-rw-r--r--php-pear-dev.spec10
2 files changed, 27 insertions, 7 deletions
diff --git a/php-pear-1.10-metadata.patch b/php-pear-1.10-metadata.patch
index bc92d0d..8c6aba8 100644
--- a/php-pear-1.10-metadata.patch
+++ b/php-pear-1.10-metadata.patch
@@ -1,6 +1,6 @@
diff -up PEAR/Command/Install.php.metadata PEAR/Command/Install.php
--- PEAR/Command/Install.php.metadata 2015-07-25 13:41:42.000000000 +0200
-+++ PEAR/Command/Install.php 2015-07-25 17:07:55.601684682 +0200
++++ PEAR/Command/Install.php 2015-07-26 10:11:07.091721550 +0200
@@ -555,7 +555,13 @@ Run post-installation scripts in package
$packrootphp_dir = $this->installer->_prependPath(
$this->config->get('php_dir', null, 'pear.php.net'),
@@ -18,7 +18,7 @@ diff -up PEAR/Command/Install.php.metadata PEAR/Command/Install.php
$this->ui->outputData('using package root: ' . $options['packagingroot']);
diff -up PEAR/Config.php.metadata PEAR/Config.php
--- PEAR/Config.php.metadata 2015-07-25 13:41:42.000000000 +0200
-+++ PEAR/Config.php 2015-07-25 17:14:09.956196305 +0200
++++ PEAR/Config.php 2015-07-26 10:11:07.091721550 +0200
@@ -86,6 +86,13 @@ if (getenv('PHP_PEAR_INSTALL_DIR')) {
}
}
@@ -104,7 +104,7 @@ diff -up PEAR/Config.php.metadata PEAR/Config.php
}
diff -up PEAR/DependencyDB.php.metadata PEAR/DependencyDB.php
--- PEAR/DependencyDB.php.metadata 2015-07-25 13:41:42.000000000 +0200
-+++ PEAR/DependencyDB.php 2015-07-25 17:07:55.602684685 +0200
++++ PEAR/DependencyDB.php 2015-07-26 10:11:07.091721550 +0200
@@ -120,8 +120,11 @@ class PEAR_DependencyDB
$this->_registry = &$this->_config->getRegistry();
@@ -126,9 +126,21 @@ diff -up PEAR/DependencyDB.php.metadata PEAR/DependencyDB.php
-}
\ Pas de fin de ligne à la fin du fichier
+}
+diff -up PEAR/Downloader/Package.php.metadata PEAR/Downloader/Package.php
+--- PEAR/Downloader/Package.php.metadata 2015-07-26 10:12:03.102981107 +0200
++++ PEAR/Downloader/Package.php 2015-07-26 10:12:07.048999397 +0200
+@@ -413,7 +413,7 @@ class PEAR_Downloader_Package
+ if ($param->_installRegistry->packageExists($package, $channel)) {
+ $packageVersion = $param->_installRegistry->packageInfo($package, 'version', $channel);
+ if (version_compare($packageVersion, $param->getVersion(), '==')) {
+- if (!isset($options['force'])) {
++ if (!isset($options['force']) && !isset($options['packagingroot'])) {
+ $info = $param->getParsedPackage();
+ unset($info['version']);
+ unset($info['state']);
diff -up PEAR/Installer.php.metadata PEAR/Installer.php
---- PEAR/Installer.php.metadata 2015-07-25 17:16:56.954883069 +0200
-+++ PEAR/Installer.php 2015-07-25 17:17:16.672964162 +0200
+--- PEAR/Installer.php.metadata 2015-07-25 13:41:42.000000000 +0200
++++ PEAR/Installer.php 2015-07-26 10:11:07.092721555 +0200
@@ -1128,15 +1128,6 @@ class PEAR_Installer extends PEAR_Downlo
$pkgname = $pkg->getName();
@@ -170,7 +182,7 @@ diff -up PEAR/Installer.php.metadata PEAR/Installer.php
$chanobj = $this->_registry->getChannel($channel, true);
diff -up PEAR/Registry.php.metadata PEAR/Registry.php
--- PEAR/Registry.php.metadata 2015-07-25 13:41:42.000000000 +0200
-+++ PEAR/Registry.php 2015-07-25 17:21:10.112933225 +0200
++++ PEAR/Registry.php 2015-07-26 10:11:07.092721555 +0200
@@ -131,23 +131,26 @@ class PEAR_Registry extends PEAR
* @access public
*/
diff --git a/php-pear-dev.spec b/php-pear-dev.spec
index fc5a651..87e6f50 100644
--- a/php-pear-dev.spec
+++ b/php-pear-dev.spec
@@ -33,7 +33,7 @@
Summary: PHP Extension and Application Repository framework
Name: %{?scl_prefix}php-pear
Version: 1.10.0
-Release: 0.1.%{pearprever}%{?dist}
+Release: 0.2.%{pearprever}%{?dist}
Epoch: 1
# PEAR, Archive_Tar, XML_Util, Console_Getopt are BSD
# Structures_Graph is LGPLv3+
@@ -62,8 +62,10 @@ Source33: pear.conf.5
# From RHEL: ignore REST cache creation failures as non-root user (#747361)
# TODO See https://github.com/pear/pear-core/commit/dfef86e05211d2abc7870209d69064d448ef53b3#PEAR/REST.php
+# https://github.com/pear/pear-core/pull/42
Patch0: php-pear-1.10-restcache.patch
# Relocate Metadata
+# https://github.com/pear/pear-core/pull/43
Patch1: php-pear-1.10-metadata.patch
BuildArch: noarch
@@ -76,6 +78,9 @@ BuildRequires: gnupg
BuildRequires: %{_bindir}/phpunit
%endif
+# Temporary
+%{?scl:Obsoletes: %{scl_prefix}fakepear}
+
Provides: %{?scl_prefix}php-pear(Console_Getopt) = %{getoptver}
Provides: %{?scl_prefix}php-pear(Archive_Tar) = %{arctarver}
Provides: %{?scl_prefix}php-pear(PEAR) = %{version}
@@ -400,6 +405,9 @@ fi
%changelog
+* Sun Jul 26 2015 Remi Collet <remi@fedoraproject.org> 1:1.10.0-0.2.dev1
+- improve metadata patch
+
* Sat Jul 25 2015 Remi Collet <remi@fedoraproject.org> 1:1.10.0-0.1.dev1
- update PEAR 1.10.0dev1 (for PHP7)