summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-08-13 11:37:18 +0200
committerRemi Collet <fedora@famillecollet.com>2012-08-13 11:37:18 +0200
commitd6499afdd87023a50f23047baf824956b2a0f1d2 (patch)
treed579f993f72309ca110e51792e4b73090d96f4f5
parentbdd7b954ad27bb276a0ef0a81d4640ea7e1dab66 (diff)
emove XML_RPC, move tests to /usr/share/tests/pear
-rw-r--r--LICENSE-XML_RPC68
-rw-r--r--install-pear.php42
-rw-r--r--php-pear.spec31
3 files changed, 47 insertions, 94 deletions
diff --git a/LICENSE-XML_RPC b/LICENSE-XML_RPC
deleted file mode 100644
index 3cc8b77..0000000
--- a/LICENSE-XML_RPC
+++ /dev/null
@@ -1,68 +0,0 @@
---------------------------------------------------------------------
- The PHP License, version 3.01
-Copyright (c) 1999 - 2010 The PHP Group. All rights reserved.
---------------------------------------------------------------------
-
-Redistribution and use in source and binary forms, with or without
-modification, is permitted provided that the following conditions
-are met:
-
- 1. Redistributions of source code must retain the above copyright
- notice, this list of conditions and the following disclaimer.
-
- 2. Redistributions in binary form must reproduce the above copyright
- notice, this list of conditions and the following disclaimer in
- the documentation and/or other materials provided with the
- distribution.
-
- 3. The name "PHP" must not be used to endorse or promote products
- derived from this software without prior written permission. For
- written permission, please contact group@php.net.
-
- 4. Products derived from this software may not be called "PHP", nor
- may "PHP" appear in their name, without prior written permission
- from group@php.net. You may indicate that your software works in
- conjunction with PHP by saying "Foo for PHP" instead of calling
- it "PHP Foo" or "phpfoo"
-
- 5. The PHP Group may publish revised and/or new versions of the
- license from time to time. Each version will be given a
- distinguishing version number.
- Once covered code has been published under a particular version
- of the license, you may always continue to use it under the terms
- of that version. You may also choose to use such covered code
- under the terms of any subsequent version of the license
- published by the PHP Group. No one other than the PHP Group has
- the right to modify the terms applicable to covered code created
- under this License.
-
- 6. Redistributions of any form whatsoever must retain the following
- acknowledgment:
- "This product includes PHP software, freely available from
- <http://www.php.net/software/>".
-
-THIS SOFTWARE IS PROVIDED BY THE PHP DEVELOPMENT TEAM ``AS IS'' AND
-ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO,
-THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
-PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE PHP
-DEVELOPMENT TEAM OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT,
-INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
-(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR
-SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION)
-HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT,
-STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
-ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED
-OF THE POSSIBILITY OF SUCH DAMAGE.
-
---------------------------------------------------------------------
-
-This software consists of voluntary contributions made by many
-individuals on behalf of the PHP Group.
-
-The PHP Group can be contacted via Email at group@php.net.
-
-For more information on the PHP Group and the PHP project,
-please see <http://www.php.net>.
-
-PHP includes the Zend Engine, freely available at
-<http://www.zend.com>.
diff --git a/install-pear.php b/install-pear.php
index a8ca995..c06dc04 100644
--- a/install-pear.php
+++ b/install-pear.php
@@ -43,7 +43,7 @@ for ($i = 0; $i < sizeof($argv); $i++) {
if (preg_match('/package-(.*)\.xml$/', $bn, $matches) ||
preg_match('/([A-Za-z0-9_:]+)-.*\.(tar|tgz)$/', $bn, $matches)) {
$install_files[$matches[1]] = $arg;
- } elseif ($arg == '-a') {
+ } elseif ($arg == '-a' || $arg == '--cache') {
$cache_dir = $argv[$i+1];
$i++;
} elseif ($arg == '--force') {
@@ -54,30 +54,36 @@ for ($i = 0; $i < sizeof($argv); $i++) {
} elseif ($arg == '-ds') {
$suffix = $argv[$i+1];
$i++;
- } elseif ($arg == '-d') {
+ } elseif ($arg == '-d' || $arg == '--dir') {
$with_dir = $argv[$i+1];
$i++;
- } elseif ($arg == '-b') {
+ } elseif ($arg == '-b' || $arg == '--bin') {
$bin_dir = $argv[$i+1];
$i++;
- } elseif ($arg == '-c') {
+ } elseif ($arg == '-c' || $arg == '--config') {
$cfg_dir = $argv[$i+1];
$i++;
- } elseif ($arg == '-w') {
+ } elseif ($arg == '-w' || $arg == '--www') {
$www_dir = $argv[$i+1];
$i++;
- } elseif ($arg == '-p') {
+ } elseif ($arg == '-p' || $arg == '--php') {
$php_bin = $argv[$i+1];
$i++;
- } elseif ($arg == '-o') {
+ } elseif ($arg == '-o' || $arg == '--download') {
$download_dir = $argv[$i+1];
$i++;
- } elseif ($arg == '-t') {
+ } elseif ($arg == '-t' || $arg == '--temp') {
$temp_dir = $argv[$i+1];
$i++;
- } elseif ($arg == '-D') {
+ } elseif ($arg == '-A' || $arg == '--data') {
+ $data_dir = $argv[$i+1];
+ $i++;
+ } elseif ($arg == '-D' || $arg == '--doc') {
$doc_dir = $argv[$i+1];
$i++;
+ } elseif ($arg == '-T' || $arg == '--test') {
+ $test_dir = $argv[$i+1];
+ $i++;
} elseif ($arg == '--debug') {
$debug = 1;
} elseif ($arg == '--extremedebug') {
@@ -139,6 +145,16 @@ if (!empty($doc_dir)) {
$config->set('doc_dir', $doc_dir, 'default');
}
+// Data files
+if (!empty($data_dir)) {
+ $config->set('data_dir', $data_dir, 'default');
+}
+
+// Unit tests
+if (!empty($test_dir)) {
+ $config->set('test_dir', $test_dir, 'default');
+}
+
// User supplied a dir prefix
if (!empty($with_dir)) {
$ds = DIRECTORY_SEPARATOR;
@@ -146,8 +162,12 @@ if (!empty($with_dir)) {
if (empty($doc_dir)) {
$config->set('doc_dir', $with_dir . $ds . 'doc', 'default');
}
- $config->set('data_dir', $with_dir . $ds . 'data', 'default');
- $config->set('test_dir', $with_dir . $ds . 'test', 'default');
+ if (empty($data_dir)) {
+ $config->set('data_dir', $with_dir . $ds . 'data', 'default');
+ }
+ if (empty($test_dir)) {
+ $config->set('test_dir', $with_dir . $ds . 'test', 'default');
+ }
if (empty($www_dir)) {
$config->set('www_dir', $with_dir . $ds . 'htdocs', 'default');
}
diff --git a/php-pear.spec b/php-pear.spec
index 5d55cd2..4d9023c 100644
--- a/php-pear.spec
+++ b/php-pear.spec
@@ -1,8 +1,5 @@
%global peardir %{_datadir}/pear
-# https://pear.php.net/bugs/bug.php?id=19368
-# XML_RPC Please Provides LICENSE file
-%global xmlrpcver 1.5.5
%global getoptver 1.3.1
%global arctarver 1.3.10
# https://pear.php.net/bugs/bug.php?id=19367
@@ -17,10 +14,10 @@
Summary: PHP Extension and Application Repository framework
Name: php-pear
Version: 1.9.4
-Release: 8%{?dist}
+Release: 9%{?dist}
Epoch: 1
# PEAR, Archive_Tar, XML_Util are BSD
-# XML-RPC, Console_Getopt are PHP
+# Console_Getopt are PHP
# Structures_Graph is LGPLv2+
License: BSD and PHP and LGPLv2+
Group: Development/Languages
@@ -30,17 +27,16 @@ Source0: http://download.pear.php.net/package/PEAR-%{version}.tgz
Source1: install-pear.php
Source2: relocate.php
Source3: strip.php
-Source4: LICENSE-XML_RPC
Source10: pear.sh
Source11: pecl.sh
Source12: peardev.sh
Source13: macros.pear
-Source20: http://pear.php.net/get/XML_RPC-%{xmlrpcver}.tgz
Source21: http://pear.php.net/get/Archive_Tar-%{arctarver}.tgz
Source22: http://pear.php.net/get/Console_Getopt-%{getoptver}.tgz
Source23: http://pear.php.net/get/Structures_Graph-%{structver}.tgz
Source24: http://pear.php.net/get/XML_Util-%{xmlutil}.tgz
# From RHEL: ignore REST cache creation failures as non-root user (#747361)
+# TODO See https://github.com/pear/pear-core/commit/dfef86e05211d2abc7870209d69064d448ef53b3#PEAR/REST.php
Patch0: php-pear-1.9.4-restcache.patch
BuildArch: noarch
@@ -54,7 +50,6 @@ Provides: php-pear(Console_Getopt) = %{getoptver}
Provides: php-pear(Archive_Tar) = %{arctarver}
Provides: php-pear(PEAR) = %{version}
Provides: php-pear(Structures_Graph) = %{structver}
-Provides: php-pear(XML_RPC) = %{xmlrpcver}
Provides: php-pear(XML_Util) = %{xmlutil}
Obsoletes: php-pear-XML-Util < %{xmlutil}-%{release}
Provides: php-pear-XML-Util = %{xmlutil}-%{release}
@@ -110,12 +105,13 @@ export INSTALL_ROOT=$RPM_BUILD_ROOT
%{_bindir}/php -n -dmemory_limit=32M -dshort_open_tag=0 -dsafe_mode=0 \
-derror_reporting=E_ALL -ddetect_unicode=0 \
- %{SOURCE1} -d %{peardir} \
- -c %{_sysconfdir}/pear \
- -b %{_bindir} \
- -w %{_localstatedir}/www/html \
- -D %{_docdir}/pear \
- %{SOURCE0} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24} %{SOURCE20}
+ %{SOURCE1} --dir %{peardir} \
+ --config %{_sysconfdir}/pear \
+ --bin %{_bindir} \
+ --www %{_localstatedir}/www/html \
+ --doc %{_docdir}/pear \
+ --test %{_datarootdir}/tests/pear \
+ %{SOURCE0} %{SOURCE21} %{SOURCE22} %{SOURCE23} %{SOURCE24}
# Replace /usr/bin/* with simple scripts:
install -m 755 %{SOURCE10} $RPM_BUILD_ROOT%{_bindir}/pear
@@ -130,7 +126,6 @@ install -m 755 %{SOURCE12} $RPM_BUILD_ROOT%{_bindir}/peardev
%{_bindir}/php -r "print_r(unserialize(substr(file_get_contents('$RPM_BUILD_ROOT%{_sysconfdir}/pear.conf'),17)));"
-install -m 644 -c %{SOURCE4} LICENSE-XML_RPC
install -m 644 -c %{SOURCE13} \
$RPM_BUILD_ROOT%{_sysconfdir}/rpm/macros.pear
@@ -198,9 +193,15 @@ rm new-pear.conf
%doc README* LICENSE*
%dir %{_docdir}/pear
%doc %{_docdir}/pear/*
+%dir %{_datarootdir}/tests
+%{_datarootdir}/tests/pear
%changelog
+* Mon Aug 13 2012 Remi Collet <remi@fedoraproject.org> 1:1.9.4-9
+- move test to /usr/share/tests/pear
+- remove XML_RPC
+
* Fri Jul 20 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:1.9.4-8
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild