summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-11-23 11:12:42 +0100
committerRemi Collet <remi@php.net>2023-11-23 11:12:42 +0100
commit410352d8bda6cc88a9bc98719564d230cb10d3ac (patch)
tree1ce17179ec416c23e5798011e51a350216b6a25f
parent4c9106c8830e6d2450465267916c5936dddc6caa (diff)
fix more deprecations from
https://github.com/pear/pear-core/pull/127
-rw-r--r--pear-php82.patch22
-rw-r--r--php-pear.spec6
2 files changed, 27 insertions, 1 deletions
diff --git a/pear-php82.patch b/pear-php82.patch
index a8d6bcb..b9f9ff8 100644
--- a/pear-php82.patch
+++ b/pear-php82.patch
@@ -20,3 +20,25 @@ index fee6638f4..6dba3b010 100644
/**
* PEAR_Error constructor
+From 5a8e7eccdaa577af8ae816e60819c14669c33376 Mon Sep 17 00:00:00 2001
+From: Remi Collet <remi@remirepo.net>
+Date: Thu, 23 Nov 2023 10:46:14 +0100
+Subject: [PATCH] fix Using ${var} in strings is deprecated
+
+---
+ PEAR/Installer.php | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/PEAR/Installer.php b/PEAR/Installer.php
+index c6e4a99fc..e7f5ce107 100644
+--- a/PEAR/Installer.php
++++ b/PEAR/Installer.php
+@@ -1271,7 +1271,7 @@ function install($pkgfile, $options = array())
+ if (count($test)) {
+ $msg = "$channel/$pkgname: conflicting files found:\n";
+ $longest = max(array_map("strlen", array_keys($test)));
+- $fmt = "%${longest}s (%s)\n";
++ $fmt = "%{$longest}s (%s)\n";
+ foreach ($test as $file => $info) {
+ if (!is_array($info)) {
+ $info = array('pear.php.net', $info);
diff --git a/php-pear.spec b/php-pear.spec
index f29b3a0..99cee34 100644
--- a/php-pear.spec
+++ b/php-pear.spec
@@ -40,7 +40,7 @@
Summary: PHP Extension and Application Repository framework
Name: %{?scl_prefix}php-pear
Version: 1.10.13
-Release: 5%{?dist}
+Release: 7%{?dist}
Epoch: 1
# BSD-2-Clause: PEAR, PEAR_Manpages, Archive_Tar, Console_Getopt
# BSD-3-Clause: XML_Util
@@ -468,6 +468,10 @@ fi
%changelog
+* Thu Nov 23 2023 Remi Collet <remi@remirepo.net> - 1.10.13-7
+- fix more deprecations from
+ https://github.com/pear/pear-core/pull/127
+
* Mon Feb 20 2023 Remi Collet <remi@remirepo.net> - 1.10.13-5
- fix PHP 8.2 deprecations using patch from
https://github.com/pear/pear-core/pull/124