summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-09-04 10:41:54 +0200
committerRemi Collet <remi@remirepo.net>2017-09-04 10:41:54 +0200
commit4f316e3fc2cc9133793959b5808fd5923819265b (patch)
treea1c820d318aa2a0e46dcde49b1b5f46a6b2904d9
parent7aacd6d7dc884df1d22a991e66b61da4cda1898d (diff)
add conditions to simple merge in Fedora
-rw-r--r--php-pear-crypt-gpg.spec15
1 files changed, 14 insertions, 1 deletions
diff --git a/php-pear-crypt-gpg.spec b/php-pear-crypt-gpg.spec
index 499f265..ae65f3d 100644
--- a/php-pear-crypt-gpg.spec
+++ b/php-pear-crypt-gpg.spec
@@ -9,7 +9,14 @@
%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Crypt_GPG
+%if 0%{?rhel}
+# All features require GnuPG v1 (under investigation)
+%global with_tests 0%{?_with_tests:1}
+%else
%global with_tests 0%{!?_without_tests:1}
+%endif
+# remirepo:1
+%global with_tests 0%{?_with_tests:1}
Name: php-pear-crypt-gpg
Version: 1.6.2
@@ -21,6 +28,7 @@ License: LGPLv2+
URL: http://pear.php.net/package/%{pear_name}
Source0: http://pear.php.net/get/%{pear_name}-%{version}.tgz
+# remirepo:3
# Use /usr/bin/gpg1 if available, only in #remirepo
Patch0: %{pear_name}-gpg1.patch
@@ -29,6 +37,9 @@ BuildRequires: php-pear(PEAR)
%if %{with_tests}
# for tests
BuildRequires: php-composer(phpunit/phpunit)
+BuildRequires: %{_bindir}/gpg
+BuildRequires: %{_bindir}/gpg-agent
+# remirepo:1
BuildRequires: gnupg < 2
BuildRequires: %{_bindir}/ps
%endif
@@ -37,6 +48,8 @@ Requires(post): %{__pear}
Requires(postun): %{__pear}
Requires: php-pear(PEAR)
+Requires: %{_bindir}/gpg
+# remirepo:1
Requires: gnupg < 2
# From package.pear
Requires: php(language) >= 5.4.8
@@ -68,8 +81,8 @@ is intended only to facilitate public-key cryptography.
%{?_licensedir:sed -e '/LICENSE/d' -i package.xml}
-
cd %{pear_name}-%{version}
+# remirepo:6
if [ -x %{_bindir}/gpg1 ]; then
%patch0 -p1 -b .rpm
sed -e '/Engine.php/s/md5sum="[^"]*"//' \