summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-01-16 13:08:44 +0100
committerRemi Collet <fedora@famillecollet.com>2013-01-16 13:08:44 +0100
commit372ecd48c85338ddfcba308f6e995bc88d9a10b0 (patch)
tree25b5f11bb0879dfffbee59e972c9a56e868bb06a
parente18c2133f1f16757d8f9f0a87ca282c5bd2bd4cc (diff)
php-pear-Text-CAPTCHA: cleanups
-rw-r--r--Makefile4
-rw-r--r--php-pear-Text-CAPTCHA.spec41
2 files changed, 23 insertions, 22 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-pear-Text-CAPTCHA.spec b/php-pear-Text-CAPTCHA.spec
index 99cc30f..c732210 100644
--- a/php-pear-Text-CAPTCHA.spec
+++ b/php-pear-Text-CAPTCHA.spec
@@ -8,7 +8,7 @@ Release: 1%{?dist}
Summary: Generation of CAPTCHAs
Group: Development/Libraries
-License: BSD License
+License: BSD
URL: http://pear.php.net/package/Text_CAPTCHA
Source0: http://pear.php.net/get/%{pear_name}-%{version}.tgz
@@ -18,21 +18,26 @@ BuildRequires: php-pear(PEAR)
Requires(post): %{__pear}
Requires(postun): %{__pear}
+Requires: php-gd
Requires: php-pear(PEAR)
Requires: php-pear(Text_Password)
-Requires: php-pear(PEAR) >= 1.4.0b1
-Provides: php-pear(Text_CAPTCHA) = %{version}
+# Optional
+Requires: php-pear(Numbers_Words)
+Requires: php-pear(Text_Figlet)
+Requires: php-pear(Image_Text)
+
+Provides: php-pear(%{pear_name}) = %{version}
%description
Implementation of CAPTCHAs (completely automated public Turing test to tell
computers and humans apart)
+
%prep
%setup -q -c
-[ -f package2.xml ] || mv package.xml package2.xml
-mv package2.xml %{pear_name}-%{version}/%{name}.xml
cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
%build
@@ -41,20 +46,20 @@ cd %{pear_name}-%{version}
%install
+rm -rf %{buildroot}
cd %{pear_name}-%{version}
-rm -rf $RPM_BUILD_ROOT
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%clean
-rm -rf $RPM_BUILD_ROOT
+rm -rf %{buildroot}
%post
@@ -71,19 +76,11 @@ fi
%files
%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
-
-
%{pear_xmldir}/%{name}.xml
-# Expand this as needed to avoid owning dirs owned by our dependencies
-# and to avoid unowned dirs
-%{pear_phpdir}/Text/CAPTCHA/Driver/Equation.php
-%{pear_phpdir}/Text/CAPTCHA/Driver/Figlet.php
-%{pear_phpdir}/Text/CAPTCHA/Driver/Image.php
-%{pear_phpdir}/Text/CAPTCHA/Driver/Numeral.php
-%{pear_phpdir}/Text/CAPTCHA/Driver/Word.php
+%{pear_phpdir}/Text/CAPTCHA
%{pear_phpdir}/Text/CAPTCHA.php
-
-
%changelog
+* Wed Jan 16 2013 Remi Collet <remi@fedoraproject.org> - 0.4.3-1
+- Initial package