summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json3
-rw-r--r--php-pear-PHP-CodeSniffer-rpm.patch24
-rw-r--r--php-pear-PHP-CodeSniffer.spec12
3 files changed, 20 insertions, 19 deletions
diff --git a/composer.json b/composer.json
index ae7c760..28cdb07 100644
--- a/composer.json
+++ b/composer.json
@@ -42,6 +42,9 @@
"bin/phpcbf",
"bin/phpcs"
],
+ "config": {
+ "lock": false
+ },
"extra": {
"branch-alias": {
"dev-master": "3.x-dev"
diff --git a/php-pear-PHP-CodeSniffer-rpm.patch b/php-pear-PHP-CodeSniffer-rpm.patch
index 66736db..082cf2d 100644
--- a/php-pear-PHP-CodeSniffer-rpm.patch
+++ b/php-pear-PHP-CodeSniffer-rpm.patch
@@ -1,31 +1,23 @@
diff -up ./bin/phpcbf.rpm ./bin/phpcbf
---- ./bin/phpcbf.rpm 2023-12-11 09:46:17.920584703 +0100
-+++ ./bin/phpcbf 2023-12-11 09:46:27.469951577 +0100
-@@ -8,11 +8,7 @@
+--- ./bin/phpcbf.rpm 2024-04-02 07:58:25.996735959 +0200
++++ ./bin/phpcbf 2024-04-02 07:59:09.906379098 +0200
+@@ -8,7 +8,7 @@
* @license https://github.com/PHPCSStandards/PHP_CodeSniffer/blob/master/licence.txt BSD Licence
*/
--if (is_file(__DIR__.'/../autoload.php') === true) {
-- include_once __DIR__.'/../autoload.php';
--} else {
-- include_once 'PHP/CodeSniffer/autoload.php';
--}
+-require_once __DIR__.'/../autoload.php';
+include_once '/usr/share/pear/PHP/CodeSniffer/autoload.php';
$runner = new PHP_CodeSniffer\Runner();
$exitCode = $runner->runPHPCBF();
diff -up ./bin/phpcs.rpm ./bin/phpcs
---- ./bin/phpcs.rpm 2023-12-11 09:45:10.918010545 +0100
-+++ ./bin/phpcs 2023-12-11 09:46:03.104015468 +0100
-@@ -8,11 +8,7 @@
+--- ./bin/phpcs.rpm 2024-04-02 07:58:25.996735959 +0200
++++ ./bin/phpcs 2024-04-02 07:59:18.295693037 +0200
+@@ -8,7 +8,7 @@
* @license https://github.com/PHPCSStandards/PHP_CodeSniffer/blob/master/licence.txt BSD Licence
*/
--if (is_file(__DIR__.'/../autoload.php') === true) {
-- include_once __DIR__.'/../autoload.php';
--} else {
-- include_once 'PHP/CodeSniffer/autoload.php';
--}
+-require_once __DIR__.'/../autoload.php';
+include_once '/usr/share/pear/PHP/CodeSniffer/autoload.php';
$runner = new PHP_CodeSniffer\Runner();
diff --git a/php-pear-PHP-CodeSniffer.spec b/php-pear-PHP-CodeSniffer.spec
index ba811a3..4038684 100644
--- a/php-pear-PHP-CodeSniffer.spec
+++ b/php-pear-PHP-CodeSniffer.spec
@@ -16,9 +16,9 @@
%bcond_without tests
-%global gh_commit d63cee4890a8afaf86a22e51ad4d97c91dd4579b
+%global gh_commit aac1f6f347a5c5ac6bc98ad395007df00990f480
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_date 2024-02-16
+%global gh_date 2024-04-23
%global gh_owner PHPCSStandards
%global gh_project PHP_CodeSniffer
# keep in old PEAR tree
@@ -26,7 +26,7 @@
Name: php-pear-PHP-CodeSniffer
-Version: 3.9.0
+Version: 3.9.2
Release: 1%{?dist}
Summary: PHP coding standards enforcement tool
@@ -144,6 +144,12 @@ fi
%changelog
+* Wed Apr 24 2024 Remi Collet <remi@remirepo.net> - 3.9.2-1
+- update to 3.9.2
+
+* Tue Apr 2 2024 Remi Collet <remi@remirepo.net> - 3.9.1-1
+- update to 3.9.1
+
* Sat Feb 17 2024 Remi Collet <remi@remirepo.net> - 3.9.0-1
- update to 3.9.0
- drop patch merged upstream