summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-02-22 15:39:35 +0100
committerRemi Collet <fedora@famillecollet.com>2015-02-22 15:39:35 +0100
commit6e53ec8540046304d6304c5b90ab895eb3369f32 (patch)
tree70f6228ae0628855b63e9d4d74ebc78562134d0b
parente42f145a18d156807026fba82168b5c3dd746cf8 (diff)
php-pear-Net-LDAP2: 2.1.0 - New package
-rw-r--r--Makefile4
-rw-r--r--php-pear-Net-LDAP2.spec93
2 files changed, 54 insertions, 43 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..13af741
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../../common/Makefile
+
diff --git a/php-pear-Net-LDAP2.spec b/php-pear-Net-LDAP2.spec
index 4f44026..3ac73da 100644
--- a/php-pear-Net-LDAP2.spec
+++ b/php-pear-Net-LDAP2.spec
@@ -1,15 +1,27 @@
+# spec file for php-pear-Net-LDAP2
+#
+# Copyright (c) 2015 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
%{!?pear_metadir: %global pear_metadir %{pear_phpdir}}
-%{!?__pear: %{expand: %%global __pear %{_bindir}/pear}}
+%{!?__pear: %global __pear %{_bindir}/pear}
%global pear_name Net_LDAP2
+# Test suite requires a LDAP server, so are not run during build
+
Name: php-pear-Net-LDAP2
Version: 2.1.0
Release: 1%{?dist}
Summary: Object oriented interface for searching and manipulating LDAP-entries
Group: Development/Libraries
-License: LGPLv3 License
-URL: http://pear.php.net/package/Net_LDAP2
+# LGPL doesn't require license file, but ask for it
+# https://pear.php.net/bugs/bug.php?id=20504 - please include License file
+License: LGPLv3
+URL: http://pear.php.net/package/%{pear_name}
Source0: http://pear.php.net/get/%{pear_name}-%{version}.tgz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -18,31 +30,36 @@ BuildRequires: php-pear(PEAR)
Requires(post): %{__pear}
Requires(postun): %{__pear}
+# From package.xml
Requires: php-pear(PEAR)
-Provides: php-pear(Net_LDAP2) = %{version}
+Requires: php-ldap
+# From phpcompatinfo report
+Requires: php-date
+Requires: php-pcre
+Requires: php-spl
+
+Provides: php-pear(%{pear_name}) = %{version}
+
%description
-Net_LDAP2 is the successor of Net_LDAP which is a clone of Perls Net::LDAP
- object interface to directory servers. It does contain most
-of Net::LDAPs
- features but has some own too.
- With Net_LDAP2 you have:
- * A simple object-oriented interface to connections,
-searches entries and filters.
- * Support for TLS and LDAP v3.
- * Simple modification, deletion and creation of LDAP
-entries.
- * Support for schema handling.
-
- Net_LDAP2 layers itself on top of PHP's existing ldap
-extensions.
+Net_LDAP2 is the successor of Net_LDAP (which is a clone of Perls Net::LDAP)
+object interface to directory servers. It does contain most of Net::LDAPs
+features but has some own too.
+
+With Net_LDAP2 you have:
+* A simple object-oriented interface to connections,
+ searches entries and filters.
+* Support for TLS and LDAP v3.
+* Simple modification, deletion and creation of LDAP entries.
+* Support for schema handling.
+
+Net_LDAP2 layers itself on top of PHP's existing ldap extensions.
+
%prep
%setup -q -c
-[ -f package2.xml ] || mv package.xml package2.xml
-mv package2.xml %{pear_name}-%{version}/%{name}.xml
-
cd %{pear_name}-%{version}
+mv ../package.xml %{name}.xml
%build
@@ -51,20 +68,21 @@ cd %{pear_name}-%{version}
%install
+rm -rf %{buildroot}
+
cd %{pear_name}-%{version}
-rm -rf $RPM_BUILD_ROOT
-%{__pear} install --nodeps --packagingroot $RPM_BUILD_ROOT %{name}.xml
+%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
-rm -rf $RPM_BUILD_ROOT%{pear_metadir}/.??*
+rm -rf %{buildroot}%{pear_metadir}/.??*
# Install XML package description
-mkdir -p $RPM_BUILD_ROOT%{pear_xmldir}
-install -pm 644 %{name}.xml $RPM_BUILD_ROOT%{pear_xmldir}
+mkdir -p %{buildroot}%{pear_xmldir}
+install -pm 644 %{name}.xml %{buildroot}%{pear_xmldir}
%clean
-rm -rf $RPM_BUILD_ROOT
+rm -rf %{buildroot}
%post
@@ -81,23 +99,12 @@ fi
%files
%defattr(-,root,root,-)
%doc %{pear_docdir}/%{pear_name}
-
-
%{pear_xmldir}/%{name}.xml
-# Expand this as needed to avoid owning dirs owned by our dependencies
-# and to avoid unowned dirs
-%{pear_phpdir}/Net/LDAP2/Entry.php
-%{pear_phpdir}/Net/LDAP2/Filter.php
-%{pear_phpdir}/Net/LDAP2/RootDSE.php
-%{pear_phpdir}/Net/LDAP2/Schema.php
-%{pear_phpdir}/Net/LDAP2/Search.php
-%{pear_phpdir}/Net/LDAP2/Util.php
-%{pear_phpdir}/Net/LDAP2/LDIF.php
-%{pear_phpdir}/Net/LDAP2/SchemaCache.interface.php
-%{pear_phpdir}/Net/LDAP2/SimpleFileSchemaCache.php
-%{pear_phpdir}/Net/LDAP2.php
-
-%{pear_testdir}/Net_LDAP2
+%{pear_phpdir}/Net
+%{pear_testdir}/%{pear_name}
%changelog
+* Sun Feb 22 2015 Remi Collet <remi@fedoraproject.org> - 2.1.0-1
+- Version 2.1.0 (stable), API 2.0.0 (stable)
+- Initial package \ No newline at end of file