summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-07-18 14:17:18 +0200
committerRemi Collet <fedora@famillecollet.com>2016-07-18 14:17:18 +0200
commit2af844c09e17fff4c4457c9d293d89055826a07b (patch)
treefa412b8995f19e26434824e24346da3b0bd33547
parent83206f34936bb99c23c850021026c48876c1a167 (diff)
php-pear-Console-CommandLine: 1.2.2HEADmaster
-rw-r--r--Console_CommandLine-pr8.patch149
-rw-r--r--php-pear-Console-CommandLine.spec18
2 files changed, 7 insertions, 160 deletions
diff --git a/Console_CommandLine-pr8.patch b/Console_CommandLine-pr8.patch
deleted file mode 100644
index 0850293..0000000
--- a/Console_CommandLine-pr8.patch
+++ /dev/null
@@ -1,149 +0,0 @@
-diff --git a/tests/console_commandline_addargument.phpt b/tests/console_commandline_addargument.phpt
-index eb2e3af..7f7f689 100644
---- a/tests/console_commandline_addargument.phpt
-+++ b/tests/console_commandline_addargument.phpt
-@@ -27,7 +27,7 @@ $parser->addArgument('Some invalid name');
- --EXPECTF--
- array(4) {
- ["arg1"]=>
-- object(Console_CommandLine_Argument)#5 (8) {
-+ object(Console_CommandLine_Argument)#%d (8) {
- ["multiple"]=>
- bool(false)
- ["optional"]=>
-@@ -48,7 +48,7 @@ array(4) {
- }
- }
- ["arg2"]=>
-- object(Console_CommandLine_Argument)#6 (8) {
-+ object(Console_CommandLine_Argument)#%d (8) {
- ["multiple"]=>
- bool(true)
- ["optional"]=>
-@@ -69,7 +69,7 @@ array(4) {
- }
- }
- ["arg3"]=>
-- object(Console_CommandLine_Argument)#7 (8) {
-+ object(Console_CommandLine_Argument)#%d (8) {
- ["multiple"]=>
- bool(true)
- ["optional"]=>
-@@ -90,7 +90,7 @@ array(4) {
- }
- }
- ["arg4"]=>
-- object(Console_CommandLine_Argument)#8 (8) {
-+ object(Console_CommandLine_Argument)#%d (8) {
- ["multiple"]=>
- bool(false)
- ["optional"]=>
-diff --git a/tests/console_commandline_addoption.phpt b/tests/console_commandline_addoption.phpt
-index 73da0ea..1386121 100644
---- a/tests/console_commandline_addoption.phpt
-+++ b/tests/console_commandline_addoption.phpt
-@@ -31,7 +31,7 @@ var_dump($parser->options);
- --EXPECTF--
- array(4) {
- ["opt1"]=>
-- object(Console_CommandLine_Option)#5 (14) {
-+ object(Console_CommandLine_Option)#%d (14) {
- ["short_name"]=>
- string(2) "-a"
- ["long_name"]=>
-@@ -65,7 +65,7 @@ array(4) {
- }
- }
- ["opt2"]=>
-- object(Console_CommandLine_Option)#6 (14) {
-+ object(Console_CommandLine_Option)#%d (14) {
- ["short_name"]=>
- string(2) "-b"
- ["long_name"]=>
-@@ -105,7 +105,7 @@ array(4) {
- }
- }
- ["list_opt2"]=>
-- object(Console_CommandLine_Option)#7 (14) {
-+ object(Console_CommandLine_Option)#%d (14) {
- ["short_name"]=>
- NULL
- ["long_name"]=>
-@@ -148,7 +148,7 @@ array(4) {
- }
- }
- ["opt3"]=>
-- object(Console_CommandLine_Option)#8 (14) {
-+ object(Console_CommandLine_Option)#%d (14) {
- ["short_name"]=>
- NULL
- ["long_name"]=>
-diff --git a/tests/console_commandline_parse_17.phpt b/tests/console_commandline_parse_17.phpt
-index d3f8762..23e1444 100644
---- a/tests/console_commandline_parse_17.phpt
-+++ b/tests/console_commandline_parse_17.phpt
-@@ -18,8 +18,8 @@ try {
- }
-
- ?>
----EXPECT--
--object(Console_CommandLine_Result)#18 (4) {
-+--EXPECTF--
-+object(Console_CommandLine_Result)#%d (4) {
- ["options"]=>
- array(11) {
- ["true"]=>
-diff --git a/tests/console_commandline_parse_18.phpt b/tests/console_commandline_parse_18.phpt
-index 6efc149..93250c4 100644
---- a/tests/console_commandline_parse_18.phpt
-+++ b/tests/console_commandline_parse_18.phpt
-@@ -18,8 +18,8 @@ try {
- }
-
- ?>
----EXPECT--
--object(Console_CommandLine_Result)#16 (4) {
-+--EXPECTF--
-+object(Console_CommandLine_Result)#%d (4) {
- ["options"]=>
- array(4) {
- ["verbose"]=>
-@@ -37,7 +37,7 @@ object(Console_CommandLine_Result)#16 (4) {
- ["command_name"]=>
- string(7) "install"
- ["command"]=>
-- object(Console_CommandLine_Result)#19 (4) {
-+ object(Console_CommandLine_Result)#%d (4) {
- ["options"]=>
- array(2) {
- ["force"]=>
-diff --git a/tests/console_commandline_parse_7.phpt b/tests/console_commandline_parse_7.phpt
-index 1bfb6fd..de5c6af 100644
---- a/tests/console_commandline_parse_7.phpt
-+++ b/tests/console_commandline_parse_7.phpt
-@@ -18,8 +18,8 @@ try {
- }
-
- ?>
----EXPECT--
--object(Console_CommandLine_Result)#18 (4) {
-+--EXPECTF--
-+object(Console_CommandLine_Result)#%d (4) {
- ["options"]=>
- array(11) {
- ["true"]=>
-diff --git a/tests/console_commandline_parse_8.phpt b/tests/console_commandline_parse_8.phpt
-index ceba877..0925bbe 100644
---- a/tests/console_commandline_parse_8.phpt
-+++ b/tests/console_commandline_parse_8.phpt
-@@ -19,8 +19,8 @@ try {
- }
-
- ?>
----EXPECT--
--object(Console_CommandLine_Result)#18 (4) {
-+--EXPECTF--
-+object(Console_CommandLine_Result)#%d (4) {
- ["options"]=>
- array(11) {
- ["true"]=>
diff --git a/php-pear-Console-CommandLine.spec b/php-pear-Console-CommandLine.spec
index e54ccbe..a21424a 100644
--- a/php-pear-Console-CommandLine.spec
+++ b/php-pear-Console-CommandLine.spec
@@ -1,4 +1,4 @@
-# remirepo/fedora spec file for ImageMagick
+# remirepo/fedora spec file for php-pear-Console-CommandLine
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -10,7 +10,7 @@
%global pear_name Console_CommandLine
Name: php-pear-Console-CommandLine
-Version: 1.2.1
+Version: 1.2.2
Release: 1%{?dist}
Summary: A full featured command line options and arguments parser
@@ -19,9 +19,6 @@ License: MIT
URL: http://pear.php.net/package/%{pear_name}
Source0: http://pear.php.net/get/%{pear_name}-%{version}.tgz
-# https://github.com/pear/Console_CommandLine/pull/8
-Patch1: %{pear_name}-pr8.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-pear
@@ -53,14 +50,9 @@ Main features:
%prep
%setup -qc
-# because of our patches
-sed -e 's/md5sum=.*name/name/' -i package.xml
-
cd %{pear_name}-%{version}
mv ../package.xml %{name}.xml
-%patch1 -p1 -b .pr8
-
%build
cd %{pear_name}-%{version}
@@ -68,8 +60,9 @@ cd %{pear_name}-%{version}
%install
+rm -rf %{buildroot}
+
cd %{pear_name}-%{version}
-rm -rf %{buildroot} docdir
%{__pear} install --nodeps --packagingroot %{buildroot} %{name}.xml
# Clean up unnecessary files
@@ -111,6 +104,9 @@ fi
%changelog
+* Mon Jul 18 2016 Remi Collet <remi@fedoraproject.org> - 1.2.2-1
+- Update to 1.2.2
+
* Fri Dec 11 2015 Remi Collet <remi@fedoraproject.org> - 1.2.1-1
- Update to 1.2.1
- provide php-composer(pear/console_commandline)