summaryrefslogtreecommitdiffstats
path: root/php-pda-pheanstalk.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-06-19 09:13:39 +0200
committerRemi Collet <remi@remirepo.net>2019-06-19 09:13:39 +0200
commit534c3356bd0d20cd9a5077b586f2d14f2da4e40f (patch)
tree1fb393ef3da98ca17bd315d1689c139dc98150cd /php-pda-pheanstalk.spec
parent83d256e81335022f05e6281095de7816138454ea (diff)
v4.0.0 from FedoraHEADmaster
Diffstat (limited to 'php-pda-pheanstalk.spec')
-rw-r--r--php-pda-pheanstalk.spec27
1 files changed, 15 insertions, 12 deletions
diff --git a/php-pda-pheanstalk.spec b/php-pda-pheanstalk.spec
index 416a675..41134e6 100644
--- a/php-pda-pheanstalk.spec
+++ b/php-pda-pheanstalk.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-pda-pheanstalk
#
-# Copyright (c) 2017 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2017-2019 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,14 +12,14 @@
%global github_owner pda
%global github_name pheanstalk
-%global github_version 3.1.0
-%global github_commit 430e77c551479aad0c6ada0450ee844cf656a18b
+%global github_version 4.0.0
+%global github_commit 328708b2cb843c214579a9ac3d1730c074038d6a
%global composer_vendor pda
%global composer_project pheanstalk
-# "php": ">=5.3.0"
-%global php_min_ver 5.3.0
+# "php": ">=7.1.0"
+%global php_min_ver 7.1.0
# Build using "--without tests" to disable tests
%global with_tests 0%{!?_without_tests:1}
@@ -31,7 +31,6 @@ Version: %{github_version}
Release: 1%{?github_release}%{?dist}
Summary: PHP client for beanstalkd queue
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
@@ -46,10 +45,10 @@ BuildArch: noarch
## composer.json
BuildRequires: php(language) >= %{php_min_ver}
BuildRequires: php-composer(phpunit/phpunit)
-## phpcompatinfo (computed from version 3.1.0)
-BuildRequires: php-ctype
BuildRequires: php-mbstring
+## phpcompatinfo (computed from version 4.0.0)
BuildRequires: php-pcre
+BuildRequires: php-sockets
BuildRequires: php-spl
## Autoloader
BuildRequires: php-composer(fedora/autoloader)
@@ -57,10 +56,10 @@ BuildRequires: php-composer(fedora/autoloader)
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 3.1.0)
-Requires: php-ctype
Requires: php-mbstring
+# phpcompatinfo (computed from version 4.0.0)
Requires: php-pcre
+Requires: php-sockets
Requires: php-spl
# Autoloader
Requires: php-composer(fedora/autoloader)
@@ -118,12 +117,13 @@ cp -rp src %{buildroot}%{phpdir}/Pheanstalk
rm -f \
tests/Pheanstalk/BugfixConnectionTest.php \
tests/Pheanstalk/ConnectionTest.php \
- tests/Pheanstalk/FacadeConnectionTest.php
+ tests/Pheanstalk/PheanstalkTest.php \
+ tests/Pheanstalk/SocketFactoryTest.php
: Upstream tests
RETURN_CODE=0
PHPUNIT=$(which phpunit)
-for PHP_EXEC in php %{?rhel:php54 php55} php56 php70 php71 php72; do
+for PHP_EXEC in php php72 php73 php74; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
$PHP_EXEC $PHPUNIT --verbose \
--bootstrap %{buildroot}%{phpdir}/Pheanstalk/autoload.php \
@@ -145,5 +145,8 @@ exit $RETURN_CODE
%changelog
+* Sun Jun 16 2019 Shawn Iwinski <shawn@iwin.ski> - 4.0.0-1
+- Update to 4.0.0 (RHBZ #1653281)
+
* Sat Oct 21 2017 Shawn Iwinski <shawn@iwin.ski> - 3.1.0-1
- Initial package