summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-10-15 07:43:12 +0200
committerRemi Collet <fedora@famillecollet.com>2015-10-15 07:43:12 +0200
commit2fbdcc5979e8235b7d94a746d8323d8a5ee76955 (patch)
tree6ab87f25f375e690306af4d3fbc512288ed8ab09
parent37a9f5d7763cb79bcb3a0a40fd9ca206a73d21e5 (diff)
php-patchwork-utf8: 1.2.5
-rwxr-xr-xphp-patchwork-utf8-get-source.sh4
-rw-r--r--php-patchwork-utf8.spec15
2 files changed, 9 insertions, 10 deletions
diff --git a/php-patchwork-utf8-get-source.sh b/php-patchwork-utf8-get-source.sh
index ba71f5d..2e978ed 100755
--- a/php-patchwork-utf8-get-source.sh
+++ b/php-patchwork-utf8-get-source.sh
@@ -43,6 +43,7 @@ print "GIT_REPO = $GIT_REPO"
print "GIT_DIR = $GIT_DIR"
TEMP_DIR=$(mktemp --dir)
+SRC_DIR=$PWD
pushd $TEMP_DIR
print "Cloning git repo..."
@@ -51,6 +52,7 @@ pushd $TEMP_DIR
pushd $GIT_DIR
print "Checking out commit..."
$GIT checkout $GIT_COMMIT
+ cp composer.json ${SRC_DIR}/composer-${VERSION}.json
popd
TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
@@ -58,7 +60,7 @@ pushd $TEMP_DIR
mv $GIT_DIR $TAR_DIR
- TAR_FILE=`$RPM --eval='%{_sourcedir}'`/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+ TAR_FILE=${SRC_DIR}/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
print "TAR_FILE = $TAR_FILE"
[ -e $TAR_FILE ] && rm -f $TAR_FILE
diff --git a/php-patchwork-utf8.spec b/php-patchwork-utf8.spec
index f021d78..e148b63 100644
--- a/php-patchwork-utf8.spec
+++ b/php-patchwork-utf8.spec
@@ -12,8 +12,8 @@
%global github_owner tchwork
%global github_name utf8
-%global github_version 1.2.3
-%global github_commit a7a9a987d01d052ff9c99510ecbd07ebc6c270f2
+%global github_version 1.2.5
+%global github_commit 25a55c6c668de61cc3b97aab4237ebf6dadabe17
%global composer_vendor patchwork
%global composer_project utf8
@@ -32,7 +32,7 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 3%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: Portable and performant UTF-8, Unicode and Grapheme Clusters for PHP
Group: Development/Libraries
@@ -44,10 +44,6 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
-# Add license files
-# https://github.com/tchwork/utf8/pull/50
-Patch0: %{name}-pull-50.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Relative paths
@@ -99,8 +95,6 @@ Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
%prep
%setup -qn %{github_name}-%{github_commit}
-%patch0 -p1
-
: Create autoloader
cat <<'AUTOLOAD' | tee src/Patchwork/autoload.php
<?php
@@ -185,6 +179,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Oct 15 2015 Remi Collet <remi]remirepo.net> - 1.2.5-1
+- update to 1.2.5
+
* Wed Sep 23 2015 Remi Collet <remi]remirepo.net> - 1.2.3-3
- backport for remi repository