summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-03 09:16:20 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-03 09:16:20 +0100
commitc977e4dcd4ad87cb7165fb9da46d568052a37717 (patch)
tree6b816f5f10902bcbede700a32a943d1037358d8c
parentdc467089bb93ebd12837b2670a4962bf0c5a0fcf (diff)
php-paragonie-random-compat: add backport stuff
-rw-r--r--Makefile4
-rw-r--r--php-paragonie-random-compat.spec18
2 files changed, 22 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-paragonie-random-compat.spec b/php-paragonie-random-compat.spec
index a4179e2..83324d2 100644
--- a/php-paragonie-random-compat.spec
+++ b/php-paragonie-random-compat.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-paragonie-random-compat, from
#
# Fedora spec file for php-paragonie-random-compat
#
@@ -35,6 +36,7 @@ License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
# Tests
%if %{with_tests}
@@ -79,6 +81,8 @@ ln -s random.php lib/autoload.php
%install
+rm -rf %{buildroot}
+
mkdir -p %{buildroot}%{phpdir}/random_compat
cp -rp lib/* %{buildroot}%{phpdir}/random_compat/
@@ -87,12 +91,22 @@ cp -rp lib/* %{buildroot}%{phpdir}/random_compat/
%if %{with_tests}
%{_bindir}/phpunit --verbose \
--bootstrap %{buildroot}%{phpdir}/random_compat/autoload.php
+
+if which php70; then
+ php70 %{_bindir}/phpunit --verbose \
+ --bootstrap %{buildroot}%{phpdir}/random_compat/autoload.php
+fi
%else
: Tests skipped
%endif
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -101,6 +115,10 @@ cp -rp lib/* %{buildroot}%{phpdir}/random_compat/
%changelog
+* Thu Dec 3 2015 Remi Collet <remi@remirepo.net> - 1.1.0-2
+- backport for remi repository
+- run test suite with both php 5 and 7 when available
+
* Tue Dec 01 2015 Shawn Iwinski <shawn@iwin.ski> - 1.1.0-2
- Renamed from "php-paragonie-random_compat" ("_" => "-")
- Removed php-mcrypt suggest