summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-04 07:20:51 +0100
committerRemi Collet <fedora@famillecollet.com>2017-03-04 07:20:51 +0100
commit1e6a4e68965a8716ebc82dbd0c326b7c5c2af2ff (patch)
tree001a990283b27c887324ec72bcc87863529d00e2
parentb6324e0df7ca98b47d712bfd67bad347e2872e3c (diff)
php-paragonie-random-compat: 2.0.9
-rw-r--r--composer.json66
-rw-r--r--php-paragonie-random-compat.spec7
2 files changed, 39 insertions, 34 deletions
diff --git a/composer.json b/composer.json
index d363f4c..1c5978c 100644
--- a/composer.json
+++ b/composer.json
@@ -1,35 +1,37 @@
{
- "name": "paragonie/random_compat",
- "description": "PHP 5.x polyfill for random_bytes() and random_int() from PHP 7",
- "keywords": [
- "csprng",
- "random",
- "pseudorandom"
- ],
- "license": "MIT",
- "type": "library",
- "authors": [
- {
- "name": "Paragon Initiative Enterprises",
- "email": "security@paragonie.com",
- "homepage": "https://paragonie.com"
- }
- ],
- "support": {
- "issues": "https://github.com/paragonie/random_compat/issues",
- "email": "info@paragonie.com",
- "source": "https://github.com/paragonie/random_compat"
- },
- "require": {
- "php": ">=5.2.0"
- },
- "require-dev": {
- "phpunit/phpunit": "4.*|5.*"
- },
- "suggest": {
- "ext-libsodium": "Provides a modern crypto API that can be used to generate random bytes."
- },
- "autoload": {
- "files": ["lib/random.php"]
+ "name": "paragonie/random_compat",
+ "description": "PHP 5.x polyfill for random_bytes() and random_int() from PHP 7",
+ "keywords": [
+ "csprng",
+ "random",
+ "pseudorandom"
+ ],
+ "license": "MIT",
+ "type": "library",
+ "authors": [
+ {
+ "name": "Paragon Initiative Enterprises",
+ "email": "security@paragonie.com",
+ "homepage": "https://paragonie.com"
}
+ ],
+ "support": {
+ "issues": "https://github.com/paragonie/random_compat/issues",
+ "email": "info@paragonie.com",
+ "source": "https://github.com/paragonie/random_compat"
+ },
+ "require": {
+ "php": ">=5.2.0"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "4.*|5.*"
+ },
+ "suggest": {
+ "ext-libsodium": "Provides a modern crypto API that can be used to generate random bytes."
+ },
+ "autoload": {
+ "files": [
+ "lib/random.php"
+ ]
+ }
}
diff --git a/php-paragonie-random-compat.spec b/php-paragonie-random-compat.spec
index 4a9b965..2b49ce0 100644
--- a/php-paragonie-random-compat.spec
+++ b/php-paragonie-random-compat.spec
@@ -12,8 +12,8 @@
%global github_owner paragonie
%global github_name random_compat
-%global github_version 2.0.7
-%global github_commit b5ea1ef3d8ff10c307ba8c5945c2f134e503278f
+%global github_version 2.0.9
+%global github_commit 6968531206671f94377b01dc7888d5d1b858a01b
%global github_short %(c=%{github_commit}; echo ${c:0:7})
%global composer_vendor paragonie
@@ -126,6 +126,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Mar 4 2017 Remi Collet <remi@remirepo.net> - 2.0.9-1
+- Update to 2.0.9
+
* Tue Feb 28 2017 Remi Collet <remi@remirepo.net> - 2.0.7-1
- update to 2.0.7 (no change)