summaryrefslogtreecommitdiffstats
path: root/php-paragonie-constant-time-encoding.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-paragonie-constant-time-encoding.spec')
-rw-r--r--php-paragonie-constant-time-encoding.spec52
1 files changed, 35 insertions, 17 deletions
diff --git a/php-paragonie-constant-time-encoding.spec b/php-paragonie-constant-time-encoding.spec
index 00375c3..dc88a22 100644
--- a/php-paragonie-constant-time-encoding.spec
+++ b/php-paragonie-constant-time-encoding.spec
@@ -14,39 +14,34 @@
%global github_owner paragonie
%global github_name constant_time_encoding
-%global commit0 eccf915f45f911bfb189d1d1638d940ec6ee6e33
+%global commit0 58c3f47f650c94ec05a151692652a868995d2938
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
Name: php-%{composer_vendor}-constant-time-encoding
-Version: 2.2.2
-Release: 4%{?dist}
+Version: 2.6.3
+Release: 1%{?dist}
Summary: Constant-time Implementations of RFC 4648 Encoding
-Group: System Environment/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
-Source0: %{url}/archive/%{commit0}.tar.gz#/%{name}-%{shortcommit0}.tar.gz
+Source0: %{name}-%{version}-%{shortcommit0}.tgz
+Source1: makesrc.sh
BuildArch: noarch
-# "php": "^7"
+# "php": "^7|^8"
BuildRequires: php(language) >= 7
BuildRequires: php-mbstring
BuildRequires: php-spl
-# "phpunit/phpunit": "^6|^7",
-%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: phpunit7
-%global phpunit %{_bindir}/phpunit7
-%else
-BuildRequires: phpunit6
-%global phpunit %{_bindir}/phpunit6
-%endif
+# "phpunit/phpunit": "^6|^7|^8|^9"
+BuildRequires: phpunit9
+%global phpunit %{_bindir}/phpunit9
BuildRequires: php-fedora-autoloader-devel
-# "php": "^7"
+# "php": "^7|^8"
Requires: php(language) >= 7
Requires: php-mbstring
Requires: php-spl
@@ -70,11 +65,13 @@ mkdir -p %{buildroot}%{_datadir}/php/%{composer_namespace}
cp -pr src/* %{buildroot}%{_datadir}/php/%{composer_namespace}
%check
+%{_bindir}/phpab -t fedora -o tests/autoload.php src tests
+
ret=0
-for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72; do
+for cmdarg in php php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --no-coverage --verbose --bootstrap=src/autoload.php || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose --bootstrap=tests/autoload.php || ret=1
fi
done
exit $ret
@@ -88,6 +85,27 @@ exit $ret
%license LICENSE.txt
%changelog
+* Tue Jun 14 2022 François Kooman <fkooman@tuxed.net> - 2.6.3-1
+- update to 2.6.3
+
+* Mon Jun 13 2022 François Kooman <fkooman@tuxed.net> - 2.6.2-1
+- update to 2.6.2 (RHBZ#1494754)
+- autoload required files for tests as well
+
+* Mon Jan 17 2022 François Kooman <fkooman@tuxed.net> - 2.5.0-1
+- update to 2.5.0
+- add makesrc.sh to download source as upstream included .gitattributes to not
+ export tests
+
+* Thu Dec 10 2020 François Kooman <fkooman@tuxed.net> - 2.4.0-2
+- support PHPUnit 8/9 for future PHP 8 support (patch by Remi Collet)
+
+* Mon Dec 7 2020 François Kooman <fkooman@tuxed.net> - 2.4.0-1
+- update to 2.4.0
+
+* Wed Nov 06 2019 François Kooman <fkooman@tuxed.net> - 2.3.0-1
+- update to 2.3.0
+
* Thu May 03 2018 François Kooman <fkooman@tuxed.net> - 2.2.2-4
- also BuildRequire phpunit7 for future EL release