summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--composer.json5
-rw-r--r--php-paragonie-constant-time-encoding.spec17
2 files changed, 18 insertions, 4 deletions
diff --git a/composer.json b/composer.json
index 583fe36..2fe9717 100644
--- a/composer.json
+++ b/composer.json
@@ -47,5 +47,10 @@
"psr-4": {
"ParagonIE\\ConstantTime\\": "src/"
}
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "ParagonIE\\ConstantTime\\Tests\\": "tests/"
+ }
}
}
diff --git a/php-paragonie-constant-time-encoding.spec b/php-paragonie-constant-time-encoding.spec
index 09b634b..dc88a22 100644
--- a/php-paragonie-constant-time-encoding.spec
+++ b/php-paragonie-constant-time-encoding.spec
@@ -14,12 +14,12 @@
%global github_owner paragonie
%global github_name constant_time_encoding
-%global commit0 9229e15f2e6ba772f0c55dd6986c563b937170a8
+%global commit0 58c3f47f650c94ec05a151692652a868995d2938
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
Name: php-%{composer_vendor}-constant-time-encoding
-Version: 2.5.0
+Version: 2.6.3
Release: 1%{?dist}
Summary: Constant-time Implementations of RFC 4648 Encoding
@@ -65,11 +65,13 @@ mkdir -p %{buildroot}%{_datadir}/php/%{composer_namespace}
cp -pr src/* %{buildroot}%{_datadir}/php/%{composer_namespace}
%check
+%{_bindir}/phpab -t fedora -o tests/autoload.php src tests
+
ret=0
-for cmdarg in php74 php80 php81; do
+for cmdarg in php php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose --bootstrap=src/autoload.php || ret=1
+ $1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose --bootstrap=tests/autoload.php || ret=1
fi
done
exit $ret
@@ -83,6 +85,13 @@ exit $ret
%license LICENSE.txt
%changelog
+* Tue Jun 14 2022 François Kooman <fkooman@tuxed.net> - 2.6.3-1
+- update to 2.6.3
+
+* Mon Jun 13 2022 François Kooman <fkooman@tuxed.net> - 2.6.2-1
+- update to 2.6.2 (RHBZ#1494754)
+- autoload required files for tests as well
+
* Mon Jan 17 2022 François Kooman <fkooman@tuxed.net> - 2.5.0-1
- update to 2.5.0
- add makesrc.sh to download source as upstream included .gitattributes to not