summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-01-17 14:00:38 +0100
committerRemi Collet <remi@php.net>2022-01-17 14:00:38 +0100
commite58ed496c2123c3e3a4f0fa529d5e43eeaa24e8c (patch)
tree016a50aa869b75245b182a2fb916776ab5bbd426
parente1bb4056a0f0546f076981802ae0b253ea1811bd (diff)
update to 2.5.0
add makesrc.sh to download source as upstream included .gitattributes to not export tests
-rwxr-xr-xmakesrc.sh27
-rw-r--r--php-paragonie-constant-time-encoding.spec21
2 files changed, 38 insertions, 10 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..8352783
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,27 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global github_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global github_name/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global commit0/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-paragonie-constant-time-encoding.spec b/php-paragonie-constant-time-encoding.spec
index 95ba450..09b634b 100644
--- a/php-paragonie-constant-time-encoding.spec
+++ b/php-paragonie-constant-time-encoding.spec
@@ -14,19 +14,20 @@
%global github_owner paragonie
%global github_name constant_time_encoding
-%global commit0 f34c2b11eb9d2c9318e13540a1dbc2a3afbd939c
+%global commit0 9229e15f2e6ba772f0c55dd6986c563b937170a8
%global shortcommit0 %(c=%{commit0}; echo ${c:0:7})
Name: php-%{composer_vendor}-constant-time-encoding
-Version: 2.4.0
-Release: 2%{?dist}
+Version: 2.5.0
+Release: 1%{?dist}
Summary: Constant-time Implementations of RFC 4648 Encoding
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
-Source0: %{url}/archive/%{commit0}.tar.gz#/%{name}-%{shortcommit0}.tar.gz
+Source0: %{name}-%{version}-%{shortcommit0}.tgz
+Source1: makesrc.sh
BuildArch: noarch
@@ -35,13 +36,8 @@ BuildRequires: php(language) >= 7
BuildRequires: php-mbstring
BuildRequires: php-spl
# "phpunit/phpunit": "^6|^7|^8|^9"
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
BuildRequires: phpunit9
%global phpunit %{_bindir}/phpunit9
-%else
-BuildRequires: phpunit8
-%global phpunit %{_bindir}/phpunit8
-%endif
BuildRequires: php-fedora-autoloader-devel
@@ -70,7 +66,7 @@ cp -pr src/* %{buildroot}%{_datadir}/php/%{composer_namespace}
%check
ret=0
-for cmdarg in "php %{phpunit}" "php71 %{_bindir}/phpunit7" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for cmdarg in php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} --no-coverage --verbose --bootstrap=src/autoload.php || ret=1
@@ -87,6 +83,11 @@ exit $ret
%license LICENSE.txt
%changelog
+* Mon Jan 17 2022 François Kooman <fkooman@tuxed.net> - 2.5.0-1
+- update to 2.5.0
+- add makesrc.sh to download source as upstream included .gitattributes to not
+ export tests
+
* Thu Dec 10 2020 François Kooman <fkooman@tuxed.net> - 2.4.0-2
- support PHPUnit 8/9 for future PHP 8 support (patch by Remi Collet)