summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-05-02 06:53:13 +0200
committerRemi Collet <fedora@famillecollet.com>2016-05-02 06:53:13 +0200
commit9bd2173e4625dcb7d6f9118e397dc3cd3929ca10 (patch)
tree7e5145b568a89d85485fd764827a358561ee88ff
parentf7e7fdaa40bc8e335694afe4d9a84c3c26709484 (diff)
php-owncloud-tarstreamer: 0.1.0
-rw-r--r--composer.json32
-rw-r--r--php-owncloud-tarstreamer.spec13
2 files changed, 40 insertions, 5 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..2e26538
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,32 @@
+{
+ "name": "owncloud/tarstreamer",
+ "type": "library",
+ "description": "A library for dynamically streaming dynamic tar files without the need to have the complete file stored on the server.",
+ "keywords": [
+ "tar",
+ "archive",
+ "stream",
+ "php"
+ ],
+ "homepage": "https://github.com/owncloud/TarStreamer",
+ "license": "MIT",
+ "require": {
+ "php": ">=5.3.8"
+ },
+ "autoload": {
+ "psr-4": {
+ "ownCloud\\TarStreamer\\": "src/"
+ }
+ },
+ "archive": {
+ "exclude": [
+ "test",
+ "tests"
+ ]
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4.8",
+ "pear/pear-core-minimal": "v1.10.0alpha2",
+ "pear/archive_tar": "~1.4"
+ }
+}
diff --git a/php-owncloud-tarstreamer.spec b/php-owncloud-tarstreamer.spec
index c839ab9..47cebbe 100644
--- a/php-owncloud-tarstreamer.spec
+++ b/php-owncloud-tarstreamer.spec
@@ -6,18 +6,17 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 07b940c68382cbfbf3a42e1de307ef6b53d5d515
+%global gh_commit 859a0170de120c66b042e6c0dbc1a9979c74669b
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner owncloud
%global gh_project TarStreamer
%global with_tests 0%{!?_without_tests:1}
%global ns_vendor ownCloud
%global ns_project TarStreamer
-%global prever beta3
Name: php-owncloud-tarstreamer
-Version: 0.1
-Release: 0.1.%{prever}%{?dist}
+Version: 0.1.0
+Release: 1%{?dist}
Summary: Streaming dynamic tar files
Group: Development/Libraries
@@ -34,6 +33,7 @@ BuildRequires: php-date
BuildRequires: php-spl
BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: php-pear(Archive_Tar)
+BuildRequires: php-pecl(Xdebug)
%endif
# From composer.json
@@ -104,5 +104,8 @@ rm -rf %{buildroot}
%changelog
+* Fri May 2 2016 Remi Collet <remi@fedoraproject.org> - 0.1.0-1
+- update to 0.1.0
+
* Fri Jan 8 2016 Remi Collet <remi@fedoraproject.org> - 0.1-0.1.beta3
-- initial package \ No newline at end of file
+- initial package