summaryrefslogtreecommitdiffstats
path: root/php-oneup-flysystem-bundle.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-12-09 12:08:26 +0100
committerRemi Collet <remi@remirepo.net>2019-12-09 12:08:26 +0100
commit6cb295009449da21163da371afd6bd89e3419d1a (patch)
treeeeaf5e5d1c68ed850e75a33377647b01e1876fe9 /php-oneup-flysystem-bundle.spec
parentdb557875e11fa016e6befa333c300d7fa2127e09 (diff)
- update to 3.3.0
- raise dependency on Symfony 3.4 - allow Symfony 5
Diffstat (limited to 'php-oneup-flysystem-bundle.spec')
-rw-r--r--php-oneup-flysystem-bundle.spec64
1 files changed, 41 insertions, 23 deletions
diff --git a/php-oneup-flysystem-bundle.spec b/php-oneup-flysystem-bundle.spec
index 9694a2c..2a2027b 100644
--- a/php-oneup-flysystem-bundle.spec
+++ b/php-oneup-flysystem-bundle.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit a0582fb6af7262fd803de43605709d1ce2e48b27
+%global gh_commit eb06fdc02362504702d162564c4c2b307ff30df0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner 1up-lab
%global gh_project OneupFlysystemBundle
@@ -21,7 +21,7 @@
%global with_tests 0%{?_with_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 3.2.0
+Version: 3.3.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: Conversion of unicode, HTML and shortcode emoji
@@ -46,12 +46,13 @@ BuildRequires: php-league-flysystem >= 1.0.26
%endif
# From composer.json, "require-dev": {
# "require-dev": {
-# "phpunit/phpunit": "^4.4",
-# "symfony/finder": "^3.3|^4.0",
-# "symfony/browser-kit": "^3.3|^4.0",
-# "symfony/asset": "^3.3|^4.0",
-# "symfony/templating": "^3.3|^4.0",
-# "symfony/translation": "^3.3|^4.0",
+# "phpunit/phpunit": "^6.4",
+# "symfony/finder": "^3.4|^4.0|^5.0",
+# "symfony/browser-kit": "^3.4|^4.0|^5.0",
+# "symfony/asset": "^3.4|^4.0|^5.0",
+# "symfony/templating": "^3.4|^4.0|^5.0",
+# "symfony/translation": "^3.4|^4.0|^5.0",
+# "symfony/yaml": "^3.4|^4.0|^5.0",
# "league/flysystem-aws-s3-v2": "^1.0",
# "league/flysystem-azure-blob-storage": "^0.1",
# "league/flysystem-cached-adapter": "^1.0",
@@ -67,19 +68,21 @@ BuildRequires: php-league-flysystem >= 1.0.26
# "jenko/flysystem-gaufrette": "^1.0",
# "superbalist/flysystem-google-storage": "^4.0",
# "league/flysystem-replicate-adapter": "^1.0"
-%global phpunit %{_bindir}/phpunit
+%global phpunit %{_bindir}/phpunit6
%if 0%{?fedora} >= 27 || 0%{?rhel} >=8
-BuildRequires: (php-composer(symfony/finder) >= 3.3 with php-composer(symfony/finder) < 5)
-BuildRequires: (php-composer(symfony/browser-kit) >= 3.3 with php-composer(symfony/browser-kit) < 5)
-BuildRequires: (php-composer(symfony/asset) >= 3.3 with php-composer(symfony/asset) < 5)
-BuildRequires: (php-composer(symfony/templating) >= 3.3 with php-composer(symfony/templating) < 5)
-BuildRequires: (php-composer(symfony/translation) >= 3.3 with php-composer(symfony/translation) < 5)
+BuildRequires: (php-composer(symfony/finder) >= 3.4 with php-composer(symfony/finder) < 6)
+BuildRequires: (php-composer(symfony/browser-kit) >= 3.4 with php-composer(symfony/browser-kit) < 6)
+BuildRequires: (php-composer(symfony/asset) >= 3.4 with php-composer(symfony/asset) < 6)
+BuildRequires: (php-composer(symfony/templating) >= 3.4 with php-composer(symfony/templating) < 6)
+BuildRequires: (php-composer(symfony/translation) >= 3.4 with php-composer(symfony/translation) < 6)
+BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 6)
%else
-BuildRequires: php-symfony3-finder >= 3.3
-BuildRequires: php-symfony3-browser-kit >= 3.3
-BuildRequires: php-symfony3-asset >= 3.3
-BuildRequires: php-symfony3-templating >= 3.3
-BuildRequires: php-symfony3-translation >= 3.3
+BuildRequires: php-symfony3-finder >= 3.4
+BuildRequires: php-symfony3-browser-kit >= 3.4
+BuildRequires: php-symfony3-asset >= 3.4
+BuildRequires: php-symfony3-templating >= 3.4
+BuildRequires: php-symfony3-translation >= 3.4
+BuildRequires: php-symfony3-yaml >= 3.4
%endif
BuildRequires: %{phpunit}
# Autoloader
@@ -88,14 +91,14 @@ BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
# "php": "^7.0",
-# "symfony/framework-bundle": "^3.3|^4.0",
+# "symfony/framework-bundle": "^3.4|^4.0|^5.0",
# "league/flysystem": "^1.0.26"
Requires: php(language) >= 7.0
%if 0%{?fedora} >= 27 || 0%{?rhel} >=8
-Requires: (php-composer(symfony/framework-bundle) >= 3.3 with php-composer(symfony/framework-bundle) < 5)
+Requires: (php-composer(symfony/framework-bundle) >= 3.4 with php-composer(symfony/framework-bundle) < 6)
Requires: (php-composer(league/flysystem) >= 1.0.26 with php-composer(league/flysystem) < 2)
%else
-Requires: php-symfony3-framework-bundle >= 3.3
+Requires: php-symfony3-framework-bundle >= 3.6
Requires: php-league-flysystem >= 1.0.26
%endif
# From phpcompatinfo report for version 3.0.2
@@ -129,6 +132,7 @@ require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\', __DIR__);
\Fedora\Autoloader\Dependencies::required([
[
+ '%{_datadir}/php/Symfony5/Bundle/FrameworkBundle/autoload.php',
'%{_datadir}/php/Symfony4/Bundle/FrameworkBundle/autoload.php',
'%{_datadir}/php/Symfony3/Bundle/FrameworkBundle/autoload.php',
],
@@ -153,26 +157,35 @@ require_once '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.ph
\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\', dirname(__DIR__));
\Fedora\Autoloader\Dependencies::required([
[
+ '%{_datadir}/php/Symfony5/Component/Finder/autoload.php',
'%{_datadir}/php/Symfony4/Component/Finder/autoload.php',
'%{_datadir}/php/Symfony3/Component/Finder/autoload.php',
], [
+ '%{_datadir}/php/Symfony5/Component/BrowserKit/autoload.php',
'%{_datadir}/php/Symfony4/Component/BrowserKit/autoload.php',
'%{_datadir}/php/Symfony3/Component/BrowserKit/autoload.php',
], [
+ '%{_datadir}/php/Symfony5/Component/Asset/autoload.php',
'%{_datadir}/php/Symfony4/Component/Asset/autoload.php',
'%{_datadir}/php/Symfony3/Component/Asset/autoload.php',
], [
+ '%{_datadir}/php/Symfony5/Component/Templating/autoload.php',
'%{_datadir}/php/Symfony4/Component/Templating/autoload.php',
'%{_datadir}/php/Symfony3/Component/Templating/autoload.php',
], [
+ '%{_datadir}/php/Symfony5/Component/Translation/autoload.php',
'%{_datadir}/php/Symfony4/Component/Translation/autoload.php',
'%{_datadir}/php/Symfony3/Component/Translation/autoload.php',
+ ], [
+ '%{_datadir}/php/Symfony5/Component/Yaml/autoload.php',
+ '%{_datadir}/php/Symfony4/Component/Yaml/autoload.php',
+ '%{_datadir}/php/Symfony3/Component/Yaml/autoload.php',
],
]);
EOF
ret=0
-for cmd in php php71 php72 php73; do
+for cmd in php php71 php72 php73 php74; do
rm -rf Tests/App/cache
if which $cmd; then
$cmd %{phpunit} \
@@ -199,6 +212,11 @@ exit $ret
%changelog
+* Mon Dec 9 2019 Remi Collet <remi@remirepo.net> - 3.3.0-1
+- update to 3.3.0
+- raise dependency on Symfony 3.4
+- allow Symfony 5
+
* Mon Nov 25 2019 Remi Collet <remi@remirepo.net> - 3.2.0-1
- update to 3.2.0