summaryrefslogtreecommitdiffstats
path: root/php-oneup-flysystem-bundle.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-12-10 08:49:50 +0100
committerRemi Collet <remi@remirepo.net>2020-12-10 08:49:50 +0100
commit108eb5f74f61001491fcdde9045d58b6a37694c3 (patch)
tree0a4688eb2db6615f17c71dc3e934e380a50c2251 /php-oneup-flysystem-bundle.spec
parentcb837a837020465f4f9fc50ddbe9778dfe8c2591 (diff)
update to 3.6.0 (no change)
raise dependency on PHP 7.1
Diffstat (limited to 'php-oneup-flysystem-bundle.spec')
-rw-r--r--php-oneup-flysystem-bundle.spec63
1 files changed, 33 insertions, 30 deletions
diff --git a/php-oneup-flysystem-bundle.spec b/php-oneup-flysystem-bundle.spec
index b94de1f..803ec9f 100644
--- a/php-oneup-flysystem-bundle.spec
+++ b/php-oneup-flysystem-bundle.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit e23d73567b477b8765e7fbe6c095cc2449caaa61
+%global gh_commit 8217801569d773e121b922b55214631134e07e82
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner 1up-lab
%global gh_project OneupFlysystemBundle
@@ -21,7 +21,7 @@
%global with_tests 0%{?_with_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 3.5.0
+Version: 3.6.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: Conversion of unicode, HTML and shortcode emoji
@@ -32,7 +32,7 @@ Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: php(language) >= 7.0
+BuildRequires: php(language) >= 7.1
BuildRequires: php-reflection
BuildRequires: php-simplexml
BuildRequires: php-ftp
@@ -50,43 +50,42 @@ BuildRequires: php-league-flysystem >= 1.0.26
%endif
# From composer.json, "require-dev": {
# "require-dev": {
-# "phpunit/phpunit": "^6.4",
-# "symfony/finder": "^3.4|^4.0|^5.0",
-# "symfony/browser-kit": "^3.4|^4.0|^5.0",
-# "symfony/asset": "^3.4|^4.0|^5.0",
-# "symfony/framework-bundle": "^3.4|^4.0|^5.0",
-# "symfony/templating": "^3.4|^4.0|^5.0",
-# "symfony/translation": "^3.4|^4.0|^5.0",
-# "symfony/yaml": "^3.4|^4.0|^5.0",
+# "async-aws/flysystem-s3": "^0.4.0",
+# "jenko/flysystem-gaufrette": "^1.0",
# "league/flysystem-aws-s3-v2": "^1.0",
# "league/flysystem-azure-blob-storage": "^0.1",
# "league/flysystem-cached-adapter": "^1.0",
-# "spatie/flysystem-dropbox": "^1.0",
# "league/flysystem-gridfs": "^1.0",
# "league/flysystem-memory": "^1.0",
# "league/flysystem-rackspace": "^1.0",
+# "league/flysystem-replicate-adapter": "^1.0",
# "league/flysystem-sftp": "^1.0",
# "league/flysystem-webdav": "^1.0",
# "league/flysystem-ziparchive": "^1.0",
-# "twistor/flysystem-stream-wrapper": "^1.0",
# "litipk/flysystem-fallback-adapter": "^0.1",
-# "jenko/flysystem-gaufrette": "^1.0",
+# "phpunit/phpunit": "^6.5 || ^7.5 || ^8.5",
+# "spatie/flysystem-dropbox": "^1.0",
# "superbalist/flysystem-google-storage": "^4.0",
-# "league/flysystem-replicate-adapter": "^1.0",
-# "async-aws/flysystem-s3": "^0.4.0"
-%global phpunit %{_bindir}/phpunit6
+# "symfony/asset": "^3.4 || ^4.0 || ^5.0",
+# "symfony/browser-kit": "^3.4 || ^4.0 || ^5.0",
+# "symfony/finder": "^3.4 || ^4.0 || ^5.0",
+# "symfony/templating": "^3.4 || ^4.0 || ^5.0",
+# "symfony/translation": "^3.4 || ^4.0 || ^5.0",
+# "symfony/yaml": "^3.4 || ^4.0 || ^5.0",
+# "twistor/flysystem-stream-wrapper": "^1.0"
+%global phpunit %{_bindir}/phpunit8
%if 0%{?fedora} >= 27 || 0%{?rhel} >=8
-BuildRequires: (php-composer(symfony/finder) >= 3.4 with php-composer(symfony/finder) < 6)
-BuildRequires: (php-composer(symfony/browser-kit) >= 3.4 with php-composer(symfony/browser-kit) < 6)
BuildRequires: (php-composer(symfony/asset) >= 3.4 with php-composer(symfony/asset) < 6)
+BuildRequires: (php-composer(symfony/browser-kit) >= 3.4 with php-composer(symfony/browser-kit) < 6)
+BuildRequires: (php-composer(symfony/finder) >= 3.4 with php-composer(symfony/finder) < 6)
BuildRequires: (php-composer(symfony/framework-bundle) >= 3.4 with php-composer(symfony/framework-bundle) < 5)
BuildRequires: (php-composer(symfony/templating) >= 3.4 with php-composer(symfony/templating) < 6)
BuildRequires: (php-composer(symfony/translation) >= 3.4 with php-composer(symfony/translation) < 6)
BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 6)
%else
-BuildRequires: php-symfony3-finder >= 3.4
-BuildRequires: php-symfony3-browser-kit >= 3.4
BuildRequires: php-symfony3-asset >= 3.4
+BuildRequires: php-symfony3-browser-kit >= 3.4
+BuildRequires: php-symfony3-finder >= 3.4
BuildRequires: php-symfony3-framework-bundle >= 3.4
BuildRequires: php-symfony3-templating >= 3.4
BuildRequires: php-symfony3-translation >= 3.4
@@ -98,22 +97,22 @@ BuildRequires: php-composer(fedora/autoloader)
%endif
# From composer.json, "require": {
-# "php": "^7.0",
-# "symfony/config": "^3.4|^4.0|^5.0",
-# "symfony/dependency-injection": "^3.4|^4.0|^5.0",
-# "symfony/http-kernel": "^3.4|^4.0|^5.0",
-# "league/flysystem": "^1.0.26"
-Requires: php(language) >= 7.0
+# "php": ">=7.1",
+# "league/flysystem": "^1.0.26",
+# "symfony/config": "^3.4 || ^4.0 || ^5.0",
+# "symfony/dependency-injection": "^3.4 || ^4.0 || ^5.0",
+# "symfony/http-kernel": "^3.4 || ^4.0 || ^5.0"
+Requires: php(language) >= 7.1
%if 0%{?fedora} >= 27 || 0%{?rhel} >=8
+Requires: (php-composer(league/flysystem) >= 1.0.26 with php-composer(league/flysystem) < 2)
Requires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 6)
Requires: (php-composer(symfony/dependency-injection) >= 3.4 with php-composer(symfony/dependency-injection) < 6)
Requires: (php-composer(symfony/http-kernel) >= 3.4 with php-composer(symfony/http-kernel) < 6)
-Requires: (php-composer(league/flysystem) >= 1.0.26 with php-composer(league/flysystem) < 2)
%else
+Requires: php-league-flysystem >= 1.0.26
Requires: php-symfony3-config >= 3.4
Requires: php-symfony3-dependency-injection >= 3.4
Requires: php-symfony3-http-kernel >= 3.4
-Requires: php-league-flysystem >= 1.0.26
%endif
# From phpcompatinfo report for version 3.0.2
Requires: php-reflection
@@ -211,7 +210,7 @@ require_once '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.ph
EOF
ret=0
-for cmd in php php71 php72 php73 php74; do
+for cmd in php php71 php72 php73 php74 php80; do
rm -rf Tests/App/cache
if which $cmd; then
$cmd %{phpunit} \
@@ -238,6 +237,10 @@ exit $ret
%changelog
+* Thu Dec 10 2020 Remi Collet <remi@remirepo.net> - 3.6.0-1
+- update to 3.6.0 (no change)
+- raise dependency on PHP 7.1
+
* Tue Jun 23 2020 Remi Collet <remi@remirepo.net> - 3.5.0-1
- update to 3.5.0