summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-01-09 16:22:08 +0100
committerRemi Collet <remi@remirepo.net>2020-01-09 16:22:08 +0100
commit217d00b3914a0afaf0ec3bee9458070754326404 (patch)
treef67664186450349e9fbf37220252c1823d930abc
parent6cb295009449da21163da371afd6bd89e3419d1a (diff)
update to 3.4.0
drop depencency on symfony/framework-bundle add dependency on symfony/config, symfony/dependency-injection and symfony/http-kernel
-rw-r--r--composer.json5
-rw-r--r--php-oneup-flysystem-bundle.spec79
2 files changed, 59 insertions, 25 deletions
diff --git a/composer.json b/composer.json
index d2e9937..eeafb74 100644
--- a/composer.json
+++ b/composer.json
@@ -22,7 +22,9 @@
"require": {
"php": "^7.0",
- "symfony/framework-bundle": "^3.4|^4.0|^5.0",
+ "symfony/config": "^3.4|^4.0|^5.0",
+ "symfony/dependency-injection": "^3.4|^4.0|^5.0",
+ "symfony/http-kernel": "^3.4|^4.0|^5.0",
"league/flysystem": "^1.0.26"
},
@@ -31,6 +33,7 @@
"symfony/finder": "^3.4|^4.0|^5.0",
"symfony/browser-kit": "^3.4|^4.0|^5.0",
"symfony/asset": "^3.4|^4.0|^5.0",
+ "symfony/framework-bundle": "^3.4|^4.0|^5.0",
"symfony/templating": "^3.4|^4.0|^5.0",
"symfony/translation": "^3.4|^4.0|^5.0",
"symfony/yaml": "^3.4|^4.0|^5.0",
diff --git a/php-oneup-flysystem-bundle.spec b/php-oneup-flysystem-bundle.spec
index 2a2027b..6678cfc 100644
--- a/php-oneup-flysystem-bundle.spec
+++ b/php-oneup-flysystem-bundle.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit eb06fdc02362504702d162564c4c2b307ff30df0
+%global gh_commit bf8b1bdc4fca6e0ad072ff917b9c9e792d682588
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner 1up-lab
%global gh_project OneupFlysystemBundle
@@ -21,7 +21,7 @@
%global with_tests 0%{?_with_tests:1}
Name: php-%{pk_vendor}-%{pk_project}
-Version: 3.3.0
+Version: 3.4.0
Release: 1%{?gh_date:.%{gh_date}git%{gh_short}}%{?dist}
Summary: Conversion of unicode, HTML and shortcode emoji
@@ -38,10 +38,14 @@ BuildRequires: php-simplexml
BuildRequires: php-ftp
BuildRequires: php-spl
%if 0%{?fedora} >= 27 || 0%{?rhel} >=8
-BuildRequires: (php-composer(symfony/framework-bundle) >= 3.3 with php-composer(symfony/framework-bundle) < 5)
-BuildRequires: (php-composer(league/flysystem) >= 1.0.26 with php-composer(league/flysystem) < 2)
+BuildRequires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 6)
+BuildRequires: (php-composer(symfony/dependency-injection) >= 3.4 with php-composer(symfony/dependency-injection) < 6)
+BuildRequires: (php-composer(symfony/http-kernel) >= 3.4 with php-composer(symfony/http-kernel) < 6)
+BuildRequires: (php-composer(league/flysystem) >= 1.0.26 with php-composer(league/flysystem) < 2)
%else
-BuildRequires: php-symfony3-framework-bundle >= 3.3
+BuildRequires: php-symfony3-config >= 3.4
+BuildRequires: php-symfony3-dependency-injection >= 3.4
+BuildRequires: php-symfony3-http-kernel >= 3.4
BuildRequires: php-league-flysystem >= 1.0.26
%endif
# From composer.json, "require-dev": {
@@ -50,6 +54,7 @@ BuildRequires: php-league-flysystem >= 1.0.26
# "symfony/finder": "^3.4|^4.0|^5.0",
# "symfony/browser-kit": "^3.4|^4.0|^5.0",
# "symfony/asset": "^3.4|^4.0|^5.0",
+# "symfony/framework-bundle": "^3.4|^4.0|^5.0",
# "symfony/templating": "^3.4|^4.0|^5.0",
# "symfony/translation": "^3.4|^4.0|^5.0",
# "symfony/yaml": "^3.4|^4.0|^5.0",
@@ -70,19 +75,21 @@ BuildRequires: php-league-flysystem >= 1.0.26
# "league/flysystem-replicate-adapter": "^1.0"
%global phpunit %{_bindir}/phpunit6
%if 0%{?fedora} >= 27 || 0%{?rhel} >=8
-BuildRequires: (php-composer(symfony/finder) >= 3.4 with php-composer(symfony/finder) < 6)
-BuildRequires: (php-composer(symfony/browser-kit) >= 3.4 with php-composer(symfony/browser-kit) < 6)
-BuildRequires: (php-composer(symfony/asset) >= 3.4 with php-composer(symfony/asset) < 6)
-BuildRequires: (php-composer(symfony/templating) >= 3.4 with php-composer(symfony/templating) < 6)
-BuildRequires: (php-composer(symfony/translation) >= 3.4 with php-composer(symfony/translation) < 6)
-BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 6)
+BuildRequires: (php-composer(symfony/finder) >= 3.4 with php-composer(symfony/finder) < 6)
+BuildRequires: (php-composer(symfony/browser-kit) >= 3.4 with php-composer(symfony/browser-kit) < 6)
+BuildRequires: (php-composer(symfony/asset) >= 3.4 with php-composer(symfony/asset) < 6)
+BuildRequires: (php-composer(symfony/framework-bundle) >= 3.4 with php-composer(symfony/framework-bundle) < 5)
+BuildRequires: (php-composer(symfony/templating) >= 3.4 with php-composer(symfony/templating) < 6)
+BuildRequires: (php-composer(symfony/translation) >= 3.4 with php-composer(symfony/translation) < 6)
+BuildRequires: (php-composer(symfony/yaml) >= 3.4 with php-composer(symfony/yaml) < 6)
%else
-BuildRequires: php-symfony3-finder >= 3.4
-BuildRequires: php-symfony3-browser-kit >= 3.4
-BuildRequires: php-symfony3-asset >= 3.4
-BuildRequires: php-symfony3-templating >= 3.4
-BuildRequires: php-symfony3-translation >= 3.4
-BuildRequires: php-symfony3-yaml >= 3.4
+BuildRequires: php-symfony3-finder >= 3.4
+BuildRequires: php-symfony3-browser-kit >= 3.4
+BuildRequires: php-symfony3-asset >= 3.4
+BuildRequires: php-symfony3-framework-bundle >= 3.4
+BuildRequires: php-symfony3-templating >= 3.4
+BuildRequires: php-symfony3-translation >= 3.4
+BuildRequires: php-symfony3-yaml >= 3.4
%endif
BuildRequires: %{phpunit}
# Autoloader
@@ -91,14 +98,20 @@ BuildRequires: php-composer(fedora/autoloader)
# From composer.json, "require": {
# "php": "^7.0",
-# "symfony/framework-bundle": "^3.4|^4.0|^5.0",
+# "symfony/config": "^3.4|^4.0|^5.0",
+# "symfony/dependency-injection": "^3.4|^4.0|^5.0",
+# "symfony/http-kernel": "^3.4|^4.0|^5.0",
# "league/flysystem": "^1.0.26"
Requires: php(language) >= 7.0
%if 0%{?fedora} >= 27 || 0%{?rhel} >=8
-Requires: (php-composer(symfony/framework-bundle) >= 3.4 with php-composer(symfony/framework-bundle) < 6)
-Requires: (php-composer(league/flysystem) >= 1.0.26 with php-composer(league/flysystem) < 2)
+Requires: (php-composer(symfony/config) >= 3.4 with php-composer(symfony/config) < 6)
+Requires: (php-composer(symfony/dependency-injection) >= 3.4 with php-composer(symfony/dependency-injection) < 6)
+Requires: (php-composer(symfony/http-kernel) >= 3.4 with php-composer(symfony/http-kernel) < 6)
+Requires: (php-composer(league/flysystem) >= 1.0.26 with php-composer(league/flysystem) < 2)
%else
-Requires: php-symfony3-framework-bundle >= 3.6
+Requires: php-symfony3-config >= 3.4
+Requires: php-symfony3-dependency-injection >= 3.4
+Requires: php-symfony3-http-kernel >= 3.4
Requires: php-league-flysystem >= 1.0.26
%endif
# From phpcompatinfo report for version 3.0.2
@@ -132,9 +145,17 @@ require_once '%{_datadir}/php/Fedora/Autoloader/autoload.php';
\Fedora\Autoloader\Autoload::addPsr4('%{ns_vendor}\\%{ns_project}\\', __DIR__);
\Fedora\Autoloader\Dependencies::required([
[
- '%{_datadir}/php/Symfony5/Bundle/FrameworkBundle/autoload.php',
- '%{_datadir}/php/Symfony4/Bundle/FrameworkBundle/autoload.php',
- '%{_datadir}/php/Symfony3/Bundle/FrameworkBundle/autoload.php',
+ '%{_datadir}/php/Symfony5/Component/Config/autoload.php',
+ '%{_datadir}/php/Symfony4/Component/Config/autoload.php',
+ '%{_datadir}/php/Symfony3/Component/Config/autoload.php',
+ ], [
+ '%{_datadir}/php/Symfony5/Component/DependencyInjection/autoload.php',
+ '%{_datadir}/php/Symfony4/Component/DependencyInjection/autoload.php',
+ '%{_datadir}/php/Symfony3/Component/DependencyInjection/autoload.php',
+ ], [
+ '%{_datadir}/php/Symfony5/Component/HttpKernel/autoload.php',
+ '%{_datadir}/php/Symfony4/Component/HttpKernel/autoload.php',
+ '%{_datadir}/php/Symfony3/Component/HttpKernel/autoload.php',
],
'%{_datadir}/php/League/Flysystem/autoload.php',
]);
@@ -169,6 +190,10 @@ require_once '%{buildroot}%{_datadir}/php/%{ns_vendor}/%{ns_project}/autoload.ph
'%{_datadir}/php/Symfony4/Component/Asset/autoload.php',
'%{_datadir}/php/Symfony3/Component/Asset/autoload.php',
], [
+ '%{_datadir}/php/Symfony5/Bundle/FrameworkBundle/autoload.php',
+ '%{_datadir}/php/Symfony4/Bundle/FrameworkBundle/autoload.php',
+ '%{_datadir}/php/Symfony3/Bundle/FrameworkBundle/autoload.php',
+ ], [
'%{_datadir}/php/Symfony5/Component/Templating/autoload.php',
'%{_datadir}/php/Symfony4/Component/Templating/autoload.php',
'%{_datadir}/php/Symfony3/Component/Templating/autoload.php',
@@ -212,6 +237,12 @@ exit $ret
%changelog
+* Thu Jan 9 2020 Remi Collet <remi@remirepo.net> - 3.4.0-1
+- update to 3.4.0
+- drop depencency on symfony/framework-bundle
+- add dependency on symfony/config, symfony/dependency-injection
+ and symfony/http-kernel
+
* Mon Dec 9 2019 Remi Collet <remi@remirepo.net> - 3.3.0-1
- update to 3.3.0
- raise dependency on Symfony 3.4