summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-24 09:05:03 +0200
committerRemi Collet <remi@remirepo.net>2020-08-24 09:05:03 +0200
commit3c0a234ce7230c9e6365d80fb1858e0c77cf352d (patch)
tree422498adab9d5ee67b16026b41a27b6348857d3a
parent905f3f9c8495bfd2a89450f63737a81d3ddfac08 (diff)
backport for remmirepo
-rw-r--r--.gitignore9
-rw-r--r--Makefile4
-rw-r--r--composer.json40
l---------makesrc.sh1
-rwxr-xr-xphp-opis-closure-get-source.sh1
-rw-r--r--php-opis-closure.spec1
6 files changed, 56 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..01f0400
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,9 @@
+clog
+package-*.xml
+*.tgz
+*.tar.bz2
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..31953f5
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,40 @@
+{
+ "name": "opis/closure",
+ "description": "A library that can be used to serialize closures (anonymous functions) and arbitrary objects.",
+ "keywords": ["closure", "serialization", "function", "serializable", "serialize", "anonymous functions"],
+ "homepage": "https://opis.io/closure",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Marius Sarca",
+ "email": "marius.sarca@gmail.com"
+ },
+ {
+ "name": "Sorin Sarca",
+ "email": "sarca_sorin@hotmail.com"
+ }
+ ],
+ "require": {
+ "php": "^5.4 || ^7.0"
+ },
+ "require-dev": {
+ "jeremeamia/superclosure": "^2.0",
+ "phpunit/phpunit": "^4.0 || ^5.0 || ^6.0 || ^7.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Opis\\Closure\\": "src/"
+ },
+ "files": ["functions.php"]
+ },
+ "autoload-dev": {
+ "psr-4": {
+ "Opis\\Closure\\Test\\": "tests/"
+ }
+ },
+ "extra": {
+ "branch-alias": {
+ "dev-master": "3.5.x-dev"
+ }
+ }
+}
diff --git a/makesrc.sh b/makesrc.sh
new file mode 120000
index 0000000..ccf895e
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1 @@
+php-opis-closure-get-source.sh \ No newline at end of file
diff --git a/php-opis-closure-get-source.sh b/php-opis-closure-get-source.sh
index fd53f46..c614ff3 100755
--- a/php-opis-closure-get-source.sh
+++ b/php-opis-closure-get-source.sh
@@ -55,6 +55,7 @@ pushd $TEMP_DIR
pushd $GIT_DIR
print "Checking out commit..."
$GIT checkout $GIT_COMMIT
+ cp composer.json ${SPEC_DIR}/
popd
TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
diff --git a/php-opis-closure.spec b/php-opis-closure.spec
index 469a42f..d560b96 100644
--- a/php-opis-closure.spec
+++ b/php-opis-closure.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-opis-closure, from
#
# Fedora spec file for php-opis-closure
#