summaryrefslogtreecommitdiffstats
path: root/php-ocramius-generated-hydrator.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-ocramius-generated-hydrator.spec')
-rw-r--r--php-ocramius-generated-hydrator.spec35
1 files changed, 20 insertions, 15 deletions
diff --git a/php-ocramius-generated-hydrator.spec b/php-ocramius-generated-hydrator.spec
index 8edbc04..3ac2e86 100644
--- a/php-ocramius-generated-hydrator.spec
+++ b/php-ocramius-generated-hydrator.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-ocramius-generated-hydrator
#
-# Copyright (c) 2014-2017 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2014-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -12,8 +12,8 @@
%global github_owner Ocramius
%global github_name GeneratedHydrator
-%global github_version 2.1.0
-%global github_commit 7cf05fe50e23e5f1c3bb063744360a23552d6075
+%global github_version 2.2.0
+%global github_commit 9b6b62db9959bec8fec88111e081e9456e36179f
%global composer_vendor ocramius
%global composer_project generated-hydrator
@@ -37,10 +37,9 @@
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 6%{?github_release}%{?dist}
+Release: 1%{?github_release}%{?dist}
Summary: An object hydrator
-Group: Development/Libraries
License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
@@ -51,9 +50,9 @@ BuildArch: noarch
BuildRequires: php(language) >= %{php_min_ver}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
-BuildRequires: (php-composer(nikic/php-parser) >= %{php_parser_min_ver} with php-composer(nikic/php-parser) < %{php_parser_max_ver})
-BuildRequires: (php-composer(ocramius/code-generator-utils) >= %{ocramius_cgu_min_ver} with php-composer(ocramius/code-generator-utils) < %{ocramius_cgu_max_ver})
-BuildRequires: (php-composer(zendframework/zend-hydrator) >= %{zf_hydrator_min_ver} with php-composer(zendframework/zend-hydrator) < %{zf_hydrator_max_ver})
+BuildRequires: (php-composer(nikic/php-parser) >= %{php_parser_min_ver} with php-composer(nikic/php-parser) < %{php_parser_max_ver})
+BuildRequires: (php-composer(ocramius/code-generator-utils) >= %{ocramius_cgu_min_ver} with php-composer(ocramius/code-generator-utils) < %{ocramius_cgu_max_ver})
+BuildRequires: (php-autoloader(zendframework/zend-hydrator) >= %{zf_hydrator_min_ver} with php-autoloader(zendframework/zend-hydrator) < %{zf_hydrator_max_ver})
# remirepo:7
%else
BuildRequires: php-nikic-php-parser3 >= %{php_parser_min_ver}
@@ -62,8 +61,8 @@ BuildRequires: php-composer(ocramius/code-generator-utils) >= %{ocramius_cgu_min
BuildRequires: php-composer(zendframework/zend-hydrator) < %{zf_hydrator_max_ver}
BuildRequires: php-composer(zendframework/zend-hydrator) >= %{zf_hydrator_min_ver}
%endif
-BuildRequires: php-composer(phpunit/phpunit) >= 5.0
-# phpcompatinfo (computed from version 2.1.0)
+BuildRequires: phpunit6 >= 6.4
+# phpcompatinfo (computed from version 2.2.0)
BuildRequires: php-date
BuildRequires: php-reflection
BuildRequires: php-spl
@@ -77,7 +76,7 @@ Requires: php(language) >= %{php_min_ver}
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
Requires: (php-composer(nikic/php-parser) >= %{php_parser_min_ver} with php-composer(nikic/php-parser) < %{php_parser_max_ver})
Requires: (php-composer(ocramius/code-generator-utils) >= %{ocramius_cgu_min_ver} with php-composer(ocramius/code-generator-utils) < %{ocramius_cgu_max_ver})
-Requires: (php-composer(zendframework/zend-hydrator) >= %{zf_hydrator_min_ver} with php-composer(zendframework/zend-hydrator) < %{zf_hydrator_max_ver})
+Requires: (php-autoloader(zendframework/zend-hydrator) >= %{zf_hydrator_min_ver} with php-autoloader(zendframework/zend-hydrator) < %{zf_hydrator_max_ver})
# remirepo:7
%else
Requires: php-nikic-php-parser3 >= %{php_parser_min_ver}
@@ -86,7 +85,7 @@ Requires: php-composer(ocramius/code-generator-utils) >= %{ocramius_cgu_min
Requires: php-composer(zendframework/zend-hydrator) < %{zf_hydrator_max_ver}
Requires: php-composer(zendframework/zend-hydrator) >= %{zf_hydrator_min_ver}
%endif
-# phpcompatinfo (computed from version 2.1.0)
+# phpcompatinfo (computed from version 2.2.0)
Requires: php-reflection
Requires: php-spl
# Autoloader
@@ -124,7 +123,7 @@ require_once '%{phpdir}/Fedora/Autoloader/autoload.php';
'%{phpdir}/PhpParser3/autoload.php',
'%{phpdir}/PhpParser2/autoload.php',
],
- '%{phpdir}/Zend/autoload.php',
+ '%{phpdir}/Zend/Hydrator/autoload.php',
]);
AUTOLOAD
@@ -148,9 +147,9 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php71 php72 php73; do
+for PHP_EXEC in php php71 php72 php73 php74; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit --verbose --bootstrap bootstrap.php \
+ $PHP_EXEC %{_bindir}/phpunit6 --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
done
@@ -161,6 +160,7 @@ exit $RETURN_CODE
%files
+# remirepo:1
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md
@@ -169,6 +169,11 @@ exit $RETURN_CODE
%changelog
+* Thu Aug 29 2019 Remi Collet <remi@remirepo.net> - 2.2.0-1
+- update to 2.2.0
+- use zendframework/zend-hydrator autoloader instead of framework one
+- switch to phpunit6
+
* Thu Nov 29 2018 Remi Collet <remi@fedoraproject.org> - 2.1.0-6
- use range dependencies and fix FTBFS