summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile4
-rw-r--r--php-ocramius-generated-hydrator.spec10
2 files changed, 14 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/php-ocramius-generated-hydrator.spec b/php-ocramius-generated-hydrator.spec
index fbc6cba..967d21b 100644
--- a/php-ocramius-generated-hydrator.spec
+++ b/php-ocramius-generated-hydrator.spec
@@ -46,6 +46,7 @@ License: MIT
URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# composer.json
@@ -92,6 +93,7 @@ arrays to objects and from objects to arrays.
%install
+rm -rf %{buildroot}
mkdir -pm 0755 %{buildroot}%{phpdir}
cp -rp src/* %{buildroot}%{phpdir}/
@@ -120,7 +122,12 @@ sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
%endif
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.md composer.json
@@ -128,5 +135,8 @@ sed 's/colors="true"/colors="false"/' phpunit.xml.dist > phpunit.xml
%changelog
+* Sat Nov 29 2014 Remi Collet <rpms@famillecollet.com> - 1.1.0-1
+- backport for remi repo
+
* Mon Oct 27 2014 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.1.0-1
- Initial package