summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-ocramius-generated-hydrator.spec25
1 files changed, 14 insertions, 11 deletions
diff --git a/php-ocramius-generated-hydrator.spec b/php-ocramius-generated-hydrator.spec
index 3ac2e86..045e987 100644
--- a/php-ocramius-generated-hydrator.spec
+++ b/php-ocramius-generated-hydrator.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-ocramius-generated-hydrator
#
-# Copyright (c) 2014-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2014-2021 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -10,6 +10,9 @@
# Please preserve changelog entries
#
+# Outdated package, ignore test suite
+%bcond_with tests
+
%global github_owner Ocramius
%global github_name GeneratedHydrator
%global github_version 2.2.0
@@ -30,14 +33,11 @@
%global zf_hydrator_min_ver 2.0
%global zf_hydrator_max_ver 3
-# Build using "--without tests" to disable tests
-%global with_tests 0%{!?_without_tests:1}
-
%{!?phpdir: %global phpdir %{_datadir}/php}
Name: php-%{composer_vendor}-%{composer_project}
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 5%{?github_release}%{?dist}
Summary: An object hydrator
License: MIT
@@ -45,7 +45,7 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{url}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# composer.json
BuildRequires: php(language) >= %{php_min_ver}
# remirepo:1
@@ -61,14 +61,14 @@ BuildRequires: php-composer(ocramius/code-generator-utils) >= %{ocramius_cgu_min
BuildRequires: php-composer(zendframework/zend-hydrator) < %{zf_hydrator_max_ver}
BuildRequires: php-composer(zendframework/zend-hydrator) >= %{zf_hydrator_min_ver}
%endif
-BuildRequires: phpunit6 >= 6.4
+BuildRequires: phpunit7
# phpcompatinfo (computed from version 2.2.0)
BuildRequires: php-date
BuildRequires: php-reflection
BuildRequires: php-spl
+%endif
# Autoloader
BuildRequires: php-composer(fedora/autoloader)
-%endif
# composer.json
Requires: php(language) >= %{php_min_ver}
@@ -135,7 +135,7 @@ cp -rp src/GeneratedHydrator %{buildroot}%{phpdir}/
%check
-%if %{with_tests}
+%if %{with tests}
: Create tests bootstrap
cat <<'BOOTSTRAP' | tee bootstrap.php
<?php
@@ -147,9 +147,9 @@ BOOTSTRAP
: Upstream tests
RETURN_CODE=0
-for PHP_EXEC in php php71 php72 php73 php74; do
+for PHP_EXEC in php php73 php74 php80; do
if [ "php" == "$PHP_EXEC" ] || which $PHP_EXEC; then
- $PHP_EXEC %{_bindir}/phpunit6 --verbose --bootstrap bootstrap.php \
+ $PHP_EXEC %{_bindir}/phpunit7 --verbose --bootstrap bootstrap.php \
|| RETURN_CODE=1
fi
done
@@ -169,6 +169,9 @@ exit $RETURN_CODE
%changelog
+* Wed Mar 24 2021 Remi Collet <remi@remirepo.net> - 2.2.0-5
+- disable tests
+
* Thu Aug 29 2019 Remi Collet <remi@remirepo.net> - 2.2.0-1
- update to 2.2.0
- use zendframework/zend-hydrator autoloader instead of framework one