summaryrefslogtreecommitdiffstats
path: root/php-nyholm-psr7.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-nyholm-psr7.spec')
-rw-r--r--php-nyholm-psr7.spec22
1 files changed, 11 insertions, 11 deletions
diff --git a/php-nyholm-psr7.spec b/php-nyholm-psr7.spec
index d9f0bb9..071884b 100644
--- a/php-nyholm-psr7.spec
+++ b/php-nyholm-psr7.spec
@@ -20,11 +20,8 @@
%global php_home %{_datadir}/php
%global ns_vendor Nyholm
%global ns_project Psr7
-%if %{bootstrap}
-%global with_tests 0%{?_with_tests:1}
-%else
-%global with_tests 0%{!?_without_tests:1}
-%endif
+
+%bcond_without tests
# php-http/psr7-integration-tests 1.1.0
%global psr7_integration_tests_commit b63c2f50c114a474086c6801aea58c0aa96f9b27
@@ -35,7 +32,7 @@
Name: php-%{pk_vendor}-%{pk_project}%{major}
Version: 1.4.0
-Release: 1%{?dist}
+Release: 2%{?dist}
Summary: A fast PHP7 implementation of PSR-7
License: MIT
@@ -51,6 +48,7 @@ BuildArch: noarch
BuildRequires: php(language) >= 7.1
BuildRequires: php-pcre
BuildRequires: php-spl
+%if %{with tests}
# remirepo:1
%if 0%{?fedora} >= 27 || 0%{?rhel} >= 8
BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
@@ -64,9 +62,6 @@ BuildRequires: php-http-message-factory
BuildRequires: php-psr-http-factory
BuildRequires: php-symfony4-error-handler >= 4.4
%endif
-# Autoloader
-BuildRequires: php-fedora-autoloader-devel >= 1.0.0
-%if %{with_tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^7.5 || 8.5 || 9.4",
# "php-http/psr7-integration-tests": "^1.0",
@@ -80,6 +75,8 @@ BuildRequires: phpunit9 >= 9.4
BuildRequires: phpunit8 >= 8.5
%endif
%endif
+# Autoloader
+BuildRequires: php-fedora-autoloader-devel >= 1.0.0
# from composer.json, "require": {
# "php": ">=7.1",
@@ -96,7 +93,7 @@ Requires: (php-composer(psr/http-factory) >= 1.0 with php-composer
%else
Requires: php-psr-http-message
Requires: php-http-message-factory
-Requires: php-psr-http-factory/usr/share/php/Psr/Http/Message/http-factory-autoload.php
+Requires: php-psr-http-factory
%endif
# from phpcompatinfo report for version 1.1.0
Requires: php-pcre
@@ -143,7 +140,7 @@ cp -pr src %{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}
%check
-%if %{with_tests}
+%if %{with tests}
mkdir vendor
cat <<EOF | tee vendor/autoload.php
<?php
@@ -185,6 +182,9 @@ exit $ret
%changelog
+* Mon Mar 22 2021 Remi Collet <remi@remirepo.net> - 1.4.0-2
+- fir for EL-7
+
* Wed Feb 24 2021 Remi Collet <remi@remirepo.net> - 1.4.0-1
- update to 1.4.0