summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-nyholm-psr7.spec14
1 files changed, 6 insertions, 8 deletions
diff --git a/php-nyholm-psr7.spec b/php-nyholm-psr7.spec
index 0a8c67e..1abc96b 100644
--- a/php-nyholm-psr7.spec
+++ b/php-nyholm-psr7.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
# github
-%global gh_commit 1461e07a0f2a975a52082ca3b769ca912b816226
+%global gh_commit f734364e38a876a23be4d906a2a089e1315be18a
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Nyholm
%global gh_project psr7
@@ -31,7 +31,7 @@
%global http_factory_tests_short %(c=%{http_factory_tests_commit}; echo ${c:0:7})
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.5.0
+Version: 1.5.1
Release: 1%{?dist}
Summary: A fast PHP7 implementation of PSR-7
@@ -67,13 +67,8 @@ BuildRequires: php-symfony4-error-handler >= 4.4
# "php-http/psr7-integration-tests": "^1.0",
# "http-interop/http-factory-tests": "^0.9",
# "symfony/error-handler": "^4.4"
-%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
%global phpunit %{_bindir}/phpunit9
BuildRequires: phpunit9 >= 9.4
-%else
-%global phpunit %{_bindir}/phpunit9
-BuildRequires: phpunit8 >= 8.5
-%endif
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
@@ -158,7 +153,7 @@ sed -e 's:./vendor/http-interop/http-factory-tests:http-factory-tests-%{http_fac
# TODO testCanDetachStream may fail on local build (extension conflicts ?)
# testIsNotSeekable|testIsNotWritable|testIsNotReadable|testRewindNotSeekable fail only in mock
ret=0
-for cmdarg in "php %{phpunit}" php74 php80 php81; do
+for cmdarg in "php %{phpunit}" php74 php80 php81 php82; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -182,6 +177,9 @@ exit $ret
%changelog
+* Wed Jun 22 2022 Remi Collet <remi@remirepo.net> - 1.5.1-1
+- update to 1.5.1
+
* Thu Feb 3 2022 Remi Collet <remi@remirepo.net> - 1.5.0-1
- update to 1.5.0