summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-05-25 09:02:21 +0200
committerRemi Collet <remi@remirepo.net>2020-05-25 09:02:21 +0200
commitac71c23a755dd235106bc487ce88da8200f23671 (patch)
tree801a10074c2117a6866fd2c6aca917005c334b74
parent29923c95beab40756695d43e084b515a87e5b9df (diff)
v1.3.0
-rw-r--r--composer.json5
-rw-r--r--php-nyholm-psr7.spec17
2 files changed, 15 insertions, 7 deletions
diff --git a/composer.json b/composer.json
index 569cf14..d4c2f59 100644
--- a/composer.json
+++ b/composer.json
@@ -22,8 +22,9 @@
},
"require-dev": {
"phpunit/phpunit": "^7.5",
- "php-http/psr7-integration-tests": "dev-master",
- "http-interop/http-factory-tests": "dev-master"
+ "php-http/psr7-integration-tests": "^1.0",
+ "http-interop/http-factory-tests": "dev-master",
+ "symfony/error-handler": "^4.4"
},
"provide": {
"psr/http-message-implementation": "1.0",
diff --git a/php-nyholm-psr7.spec b/php-nyholm-psr7.spec
index 968494e..c0c4885 100644
--- a/php-nyholm-psr7.spec
+++ b/php-nyholm-psr7.spec
@@ -8,7 +8,7 @@
#
%global bootstrap 0
# github
-%global gh_commit 55ff6b76573f5b242554c9775792bd59fb52e11c
+%global gh_commit c17f4f73985f62054a331cbc4ffdf9868c4ef256
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Nyholm
%global gh_project psr7
@@ -34,7 +34,7 @@
%global http_factory_tests_short %(c=%{http_factory_tests_commit}; echo ${c:0:7})
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.2.1
+Version: 1.3.0
Release: 1%{?dist}
Summary: A fast PHP7 implementation of PSR-7
@@ -56,19 +56,22 @@ BuildRequires: php-spl
BuildRequires: (php-composer(psr/http-message) >= 1.0 with php-composer(psr/http-message) < 2)
BuildRequires: (php-composer(php-http/message-factory) >= 1.0 with php-composer(php-http/message-factory) < 2)
BuildRequires: (php-composer(psr/http-factory) >= 1.0 with php-composer(psr/http-factory) < 2)
-# remirepo:5
+BuildRequires: (php-composer(symfony/error-handler) >= 4.4 with php-composer(symfony/error-handler) < 5)
+# remirepo:6
%else
BuildRequires: php-psr-http-message
BuildRequires: php-http-message-factory
BuildRequires: php-psr-http-factory
+BuildRequires: php-symfony4-error-handler >= 4.4
%endif
# Autoloader
BuildRequires: php-fedora-autoloader-devel >= 1.0.0
%if %{with_tests}
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^7.5",
-# "php-http/psr7-integration-tests": "dev-master",
-# "http-interop/http-factory-tests": "dev-master"
+# "php-http/psr7-integration-tests": "^1.0",
+# "http-interop/http-factory-tests": "dev-master",
+# "symfony/error-handler": "^4.4"
BuildRequires: phpunit7 > 7.5
%endif
@@ -139,6 +142,7 @@ mkdir vendor
cat <<EOF | tee vendor/autoload.php
<?php
require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}%{major}/autoload.php';
+require_once '%{php_home}/Symfony4/Component/ErrorHandler/autoload.php';
require_once dirname(__DIR__) . '/test-autoload.php';
EOF
@@ -169,6 +173,9 @@ exit $ret
%changelog
+* Mon May 25 2020 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- update to 1.3.0
+
* Fri Sep 6 2019 Remi Collet <remi@remirepo.net> - 1.2.1-1
- update to 1.2.1 (no change)