summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-03 08:38:40 +0100
committerRemi Collet <remi@php.net>2022-02-03 08:38:40 +0100
commit07e9555bce624eb7985961d8224c7dbcd269ecd3 (patch)
tree2e1211e2c0f18d976a9d675400c71b6bf7d77618
parent3f630b6593ae847a27d4ddf0884a290ab4ca9e5f (diff)
update to 1.5.0
-rw-r--r--composer.json2
-rw-r--r--php-nyholm-psr7.spec22
2 files changed, 15 insertions, 9 deletions
diff --git a/composer.json b/composer.json
index 0741e74..fffdec0 100644
--- a/composer.json
+++ b/composer.json
@@ -23,7 +23,7 @@
"require-dev": {
"phpunit/phpunit": "^7.5 || 8.5 || 9.4",
"php-http/psr7-integration-tests": "^1.0",
- "http-interop/http-factory-tests": "^0.8",
+ "http-interop/http-factory-tests": "^0.9",
"symfony/error-handler": "^4.4"
},
"provide": {
diff --git a/php-nyholm-psr7.spec b/php-nyholm-psr7.spec
index 071884b..0a8c67e 100644
--- a/php-nyholm-psr7.spec
+++ b/php-nyholm-psr7.spec
@@ -1,6 +1,6 @@
# remirepo/fedora spec file for php-nyholm-psr7
#
-# Copyright (c) 2019-2021 Remi Collet
+# Copyright (c) 2019-2022 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -8,7 +8,7 @@
#
%global bootstrap 0
# github
-%global gh_commit 23ae1f00fbc6a886cbe3062ca682391b9cc7c37b
+%global gh_commit 1461e07a0f2a975a52082ca3b769ca912b816226
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner Nyholm
%global gh_project psr7
@@ -26,13 +26,13 @@
# php-http/psr7-integration-tests 1.1.0
%global psr7_integration_tests_commit b63c2f50c114a474086c6801aea58c0aa96f9b27
%global psr7_integration_tests_short %(c=%{psr7_integration_tests_commit}; echo ${c:0:7})
-# http-interop/http-factory-tests 0.8.0
-%global http_factory_tests_commit 7384d93cd4841647b16b3c9bfd56c0367a40fce1
+# http-interop/http-factory-tests 0.9.0
+%global http_factory_tests_commit 642056c5360e8a74779cbf133afbc8aa2c174e15
%global http_factory_tests_short %(c=%{http_factory_tests_commit}; echo ${c:0:7})
Name: php-%{pk_vendor}-%{pk_project}%{major}
-Version: 1.4.0
-Release: 2%{?dist}
+Version: 1.5.0
+Release: 1%{?dist}
Summary: A fast PHP7 implementation of PSR-7
License: MIT
@@ -65,7 +65,7 @@ BuildRequires: php-symfony4-error-handler >= 4.4
# from composer.json, "require-dev": {
# "phpunit/phpunit": "^7.5 || 8.5 || 9.4",
# "php-http/psr7-integration-tests": "^1.0",
-# "http-interop/http-factory-tests": "^0.8",
+# "http-interop/http-factory-tests": "^0.9",
# "symfony/error-handler": "^4.4"
%if 0%{?fedora} >= 32 || 0%{?rhel} >= 9
%global phpunit %{_bindir}/phpunit9
@@ -158,7 +158,7 @@ sed -e 's:./vendor/http-interop/http-factory-tests:http-factory-tests-%{http_fac
# TODO testCanDetachStream may fail on local build (extension conflicts ?)
# testIsNotSeekable|testIsNotWritable|testIsNotReadable|testRewindNotSeekable fail only in mock
ret=0
-for cmdarg in "php %{phpunit}" "php72 %{_bindir}/phpunit8" php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php74 php80 php81; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit9} \
@@ -182,6 +182,12 @@ exit $ret
%changelog
+* Thu Feb 3 2022 Remi Collet <remi@remirepo.net> - 1.5.0-1
+- update to 1.5.0
+
+* Mon Jul 5 2021 Remi Collet <remi@remirepo.net> - 1.4.1-1
+- update to 1.4.1
+
* Mon Mar 22 2021 Remi Collet <remi@remirepo.net> - 1.4.0-2
- fir for EL-7