summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-nrk-Predis.spec3
1 files changed, 3 insertions, 0 deletions
diff --git a/php-nrk-Predis.spec b/php-nrk-Predis.spec
index eb761d2..c81c85a 100644
--- a/php-nrk-Predis.spec
+++ b/php-nrk-Predis.spec
@@ -97,9 +97,12 @@ redis-server \
sed -e "s/6379/$port/" phpunit.xml.dist > phpunit.xml
sed -e "/expectedExceptionMessageRegExp/s/6379/$port/" -i tests/PHPUnit/PredisConnectionTestCase.php
+# testHandlesBinaryData failing with 8.1
+# see https://github.com/predis/predis/issues/733
ret=0
php -d memory_limit=1G %{_bindir}/phpunit \
--include-path=%{buildroot}%{_datadir}/pear \
+ --filter '^((?!(testHandlesBinaryData)).)*$' \
--verbose || ret=1
: Cleanup