summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2014-11-03 10:19:23 +0100
committerRemi Collet <fedora@famillecollet.com>2014-11-03 10:19:23 +0100
commit7938b1815a1b148b186a4e8ac5786213185e8c2b (patch)
tree1ef310dd75a5e42e3018e92ba24bb112dfc04140
parenta30b08ee3a8a51be9091bb73cf22149123c3e765 (diff)
php-nrk-Predis: 1.0.0
-rw-r--r--Predis-upstream.patch60
-rw-r--r--php-nrk-Predis.spec17
2 files changed, 74 insertions, 3 deletions
diff --git a/Predis-upstream.patch b/Predis-upstream.patch
new file mode 100644
index 0000000..22bea4a
--- /dev/null
+++ b/Predis-upstream.patch
@@ -0,0 +1,60 @@
+From d09c4f32f3650d30f84c90f161304a4034a0f86f Mon Sep 17 00:00:00 2001
+From: Daniele Alessandri <suppakilla@gmail.com>
+Date: Tue, 21 Oct 2014 11:16:55 +0200
+Subject: [PATCH] [tests] Relax checks on invalid expire time messages.
+
+Previously there was a bug in Redis that returned the wrong command
+in -ERR messages when passing an invalid expire time with SETEX and
+PSETEX. Now that the bug has been fixed and that travis-ci uses a an
+updated version of Redis, our test suite turned red.
+---
+ tests/Predis/Command/StringPreciseSetExpireTest.php | 6 ++----
+ tests/Predis/Command/StringSetExpireTest.php | 4 ++--
+ 2 files changed, 4 insertions(+), 6 deletions(-)
+
+diff --git a/tests/Predis/Command/StringPreciseSetExpireTest.php b/tests/Predis/Command/StringPreciseSetExpireTest.php
+index 77df02c..c93744e 100644
+--- a/tests/Predis/Command/StringPreciseSetExpireTest.php
++++ b/tests/Predis/Command/StringPreciseSetExpireTest.php
+@@ -93,8 +93,7 @@ public function testThrowsExceptionOnNonIntegerTTL()
+ /**
+ * @group connected
+ * @expectedException \Predis\Response\ServerException
+- * @expectedExceptionMessage ERR invalid expire time in SETEX
+- * @todo Should not Redis return PSETEX instead of SETEX here?
++ * @expectedExceptionMessage ERR invalid expire time
+ */
+ public function testThrowsExceptionOnZeroTTL()
+ {
+@@ -104,8 +103,7 @@ public function testThrowsExceptionOnZeroTTL()
+ /**
+ * @group connected
+ * @expectedException \Predis\Response\ServerException
+- * @expectedExceptionMessage ERR invalid expire time in SETEX
+- * @todo Should not Redis return PSETEX instead of SETEX here?
++ * @expectedExceptionMessage ERR invalid expire time
+ */
+ public function testThrowsExceptionOnNegativeTTL()
+ {
+diff --git a/tests/Predis/Command/StringSetExpireTest.php b/tests/Predis/Command/StringSetExpireTest.php
+index 59ff77b..b52e9fa 100644
+--- a/tests/Predis/Command/StringSetExpireTest.php
++++ b/tests/Predis/Command/StringSetExpireTest.php
+@@ -94,7 +94,7 @@ public function testThrowsExceptionOnNonIntegerTTL()
+ /**
+ * @group connected
+ * @expectedException \Predis\Response\ServerException
+- * @expectedExceptionMessage ERR invalid expire time in SETEX
++ * @expectedExceptionMessage ERR invalid expire time
+ */
+ public function testThrowsExceptionOnZeroTTL()
+ {
+@@ -104,7 +104,7 @@ public function testThrowsExceptionOnZeroTTL()
+ /**
+ * @group connected
+ * @expectedException \Predis\Response\ServerException
+- * @expectedExceptionMessage ERR invalid expire time in SETEX
++ * @expectedExceptionMessage ERR invalid expire time
+ */
+ public function testThrowsExceptionOnNegativeTTL()
+ {
diff --git a/php-nrk-Predis.spec b/php-nrk-Predis.spec
index 76e66c9..41470f8 100644
--- a/php-nrk-Predis.spec
+++ b/php-nrk-Predis.spec
@@ -17,7 +17,7 @@
%endif
Name: php-nrk-Predis
-Version: 0.8.6
+Version: 1.0.0
Release: 1%{?dist}
Summary: PHP client library for Redis
@@ -26,6 +26,8 @@ License: MIT
URL: http://%{pear_channel}
Source0: http://%{pear_channel}/get/%{pear_name}-%{version}.tgz
+Patch0: %{pear_name}-upstream.patch
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php(language) >= 5.3.2
@@ -60,7 +62,12 @@ Flexible and feature-complete PHP client library for Redis.
%setup -q -c
cd %{pear_name}-%{version}
-cp ../package.xml %{name}.xml
+%patch0 -p1 -b .upstream
+
+sed -e '/StringPreciseSetExpireTest.php/s/md5sum=.*name=/name=/' \
+ -e '/StringSetExpireTest.php/s/md5sum=.*name=/name=/' \
+ ../package.xml >%{name}.xml
+touch -r ../package.xml %{name}.xml
%build
@@ -89,7 +96,7 @@ pidfile=$PWD/run/redis/redis.pid
mkdir -p {run,log,lib}/redis
sed -e "s:/var:$PWD:" \
/etc/redis.conf >redis.conf
-%{_sbindir}/redis-server \
+%{_bindir}/redis-server \
./redis.conf \
--daemonize yes \
--pidfile $pidfile
@@ -135,6 +142,10 @@ fi
%changelog
+* Mon Nov 03 2014 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- Update to 1.0.0
+- upstream patch for tests
+
* Wed Jul 16 2014 Remi Collet <remi@fedoraproject.org> - 0.8.6-1
- Update to 0.8.6
- provides php-composer(predis/predis)