summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-04-06 09:38:40 +0200
committerRemi Collet <remi@remirepo.net>2021-04-06 09:38:40 +0200
commit600846e583fe39c8e9ecb4414ec33bd53ed84d8a (patch)
treea05f187b100aa71662c267c26947381c73e327d1
parente0cc102064e022687950e9f309aa123e35c1e2f3 (diff)
update to 1.1.7
drop patch merged upstream
-rw-r--r--composer.json18
-rw-r--r--php-nrk-Predis-redis62.patch36
-rw-r--r--php-nrk-Predis.spec13
3 files changed, 11 insertions, 56 deletions
diff --git a/composer.json b/composer.json
index 4d27306..bde0b54 100644
--- a/composer.json
+++ b/composer.json
@@ -31,8 +31,7 @@
"php": ">=5.3.9"
},
"require-dev": {
- "phpunit/phpunit": "~4.8",
- "cweagans/composer-patches": "^1.6"
+ "phpunit/phpunit": "~4.8"
},
"suggest": {
"ext-phpiredis": "Allows faster serialization and deserialization of the Redis protocol",
@@ -43,16 +42,7 @@
"Predis\\": "src/"
}
},
- "extra": {
- "composer-exit-on-patch-failure": true,
- "patches": {
- "phpunit/phpunit-mock-objects": {
- "Fix PHP 7 and 8 compatibility": "./tests/phpunit_mock_objects.patch"
- },
- "phpunit/phpunit": {
- "Fix PHP 7 compatibility": "./tests/phpunit_php7.patch",
- "Fix PHP 8 compatibility": "./tests/phpunit_php8.patch"
- }
- }
- }
+ "scripts": {
+ "post-update-cmd": "@php -f tests/apply-patches.php"
+ }
}
diff --git a/php-nrk-Predis-redis62.patch b/php-nrk-Predis-redis62.patch
deleted file mode 100644
index a0ad3aa..0000000
--- a/php-nrk-Predis-redis62.patch
+++ /dev/null
@@ -1,36 +0,0 @@
-From 2f9337cb9bbebdf7334a7e58a6dc132eca013268 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@remirepo.net>
-Date: Thu, 18 Mar 2021 11:08:37 +0100
-Subject: [PATCH] fix test expectation for redis 6.2
-
----
- tests/Predis/Command/ConnectionSelectTest.php | 2 +-
- tests/Predis/Command/KeyMoveTest.php | 2 +-
- 2 files changed, 2 insertions(+), 2 deletions(-)
-
-diff --git a/tests/Predis/Command/ConnectionSelectTest.php b/tests/Predis/Command/ConnectionSelectTest.php
-index ac44e64bf..f2bcadd0a 100644
---- a/tests/Predis/Command/ConnectionSelectTest.php
-+++ b/tests/Predis/Command/ConnectionSelectTest.php
-@@ -83,7 +83,7 @@ public function testThrowsExceptionOnUnexpectedDatabaseRange()
- /**
- * @group connected
- * @expectedException \Predis\Response\ServerException
-- * @expectedExceptionMessage ERR invalid DB index
-+ * @expectedExceptionMessageRegExp /ERR (invalid DB index|value is not)/
- */
- public function testThrowsExceptionOnUnexpectedDatabaseName()
- {
-diff --git a/tests/Predis/Command/KeyMoveTest.php b/tests/Predis/Command/KeyMoveTest.php
-index c47a84ca5..ee16af41a 100644
---- a/tests/Predis/Command/KeyMoveTest.php
-+++ b/tests/Predis/Command/KeyMoveTest.php
-@@ -82,7 +82,7 @@ public function testMovesKeysToDifferentDatabases()
- /**
- * @group connected
- * @expectedException \Predis\Response\ServerException
-- * @expectedExceptionMessage ERR index out of range
-+ * @expectedExceptionMessageRegEx /ERR.*out of range/
- */
- public function testThrowsExceptionOnInvalidDatabases()
- {
diff --git a/php-nrk-Predis.spec b/php-nrk-Predis.spec
index 294d7f9..b420f58 100644
--- a/php-nrk-Predis.spec
+++ b/php-nrk-Predis.spec
@@ -15,7 +15,7 @@
%global gh_owner nrk
%global gh_project predis
-%global gh_commit 9930e933c67446962997b05201c69c2319bf26de
+%global gh_commit b240daa106d4e02f0c5b7079b41e31ddf66fddf8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global ns_project Predis
@@ -24,8 +24,8 @@
%global pear_channel pear.nrk.io
Name: php-nrk-Predis
-Version: 1.1.6
-Release: 3%{?dist}
+Version: 1.1.7
+Release: 1%{?dist}
Summary: PHP client library for Redis
License: MIT
@@ -40,8 +40,6 @@ BuildRequires: php-phpunit-PHPUnit
BuildRequires: redis
%endif
-Patch0: %{name}-redis62.patch
-
Requires: php(language) >= 5.3.9
Requires: php-reflection
Requires: php-filter
@@ -67,7 +65,6 @@ Flexible and feature-complete PHP client library for Redis.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p1
%build
@@ -135,6 +132,10 @@ fi
%changelog
+* Tue Apr 6 2021 Remi Collet <remi@remirepo.net> - 1.1.7-1
+- update to 1.1.7
+- drop patch merged upstream
+
* Thu Mar 18 2021 Remi Collet <remi@remirepo.net> - 1.1.6-3
- fix test failure with redis 6.2 using patch from
https://github.com/predis/predis/pull/686