summaryrefslogtreecommitdiffstats
path: root/php-nikic-php-parser4.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-nikic-php-parser4.spec')
-rw-r--r--php-nikic-php-parser4.spec18
1 files changed, 12 insertions, 6 deletions
diff --git a/php-nikic-php-parser4.spec b/php-nikic-php-parser4.spec
index eebe8be..2c63f74 100644
--- a/php-nikic-php-parser4.spec
+++ b/php-nikic-php-parser4.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 8c58eb4cd4f3883f82611abeac2efbc3dbed787e
+%global gh_commit 88e519766fc58bd46b8265561fb79b54e2e00b28
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nikic
%global gh_project PHP-Parser
@@ -21,7 +21,7 @@
%global major 4
Name: php-%{gh_owner}-%{pk_project}%{major}
-Version: 4.8.0
+Version: 4.9.1
Release: 1%{?dist}
Summary: A PHP parser written in PHP - version %{major}
@@ -45,8 +45,8 @@ BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^6.5 || ^7.0 || ^8.0",
-# "ircmaxell/php-yacc": "0.0.5"
+# "phpunit/phpunit": "^6.5 || ^7.0 || ^8.0 || ^9.0",
+# "ircmaxell/php-yacc": "0.0.7"
%global phpunit %{_bindir}/phpunit8
BuildRequires: phpunit8
# Autoloader
@@ -122,10 +122,10 @@ AUTOLOAD
: Upstream test suite
# ignore test failing on 32-bit (in koji)
ret=0
-for cmdarg in "php %{phpunit}" php72 php73 "php74 %{_bindir}/phpunit9" "php80 %{_bindir}/phpunit9"; do
+for cmdarg in "php %{phpunit}" "php72%{_bindir}/phpunit8" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit8} \
+ $1 ${2:-%{_bindir}/phpunit9} \
--filter '^((?!(testParse|testLexNewFeatures)).)*$' \
--verbose || ret=1
fi
@@ -147,6 +147,12 @@ exit $ret
%changelog
+* Mon Aug 31 2020 Remi Collet <remi@remirepo.net> - 4.9.1-1
+- update to 4.9.1
+
+* Wed Aug 19 2020 Remi Collet <remi@remirepo.net> - 4.9.0-1
+- update to 4.9.0
+
* Mon Aug 10 2020 Remi Collet <remi@remirepo.net> - 4.8.0-1
- update to 4.8.0