summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-12-27 06:27:31 +0100
committerRemi Collet <remi@remirepo.net>2018-12-27 06:27:31 +0100
commitec9fa5bc31ca4235695f4a8fe1c2f9b7df4aa9b1 (patch)
tree028e1f6623f45e11097fb5a16f05b796ec04f2c4
parentdc1c932786a9f53108026ab18850ee637f99aee5 (diff)
v4.1.1
-rw-r--r--php-nikic-php-parser4.spec16
1 files changed, 6 insertions, 10 deletions
diff --git a/php-nikic-php-parser4.spec b/php-nikic-php-parser4.spec
index a1df322..6aea1fe 100644
--- a/php-nikic-php-parser4.spec
+++ b/php-nikic-php-parser4.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit d0230c5c77a7e3cfa69446febf340978540958c0
+%global gh_commit 8aae5b59b83bb4d0dbf07b0a835f2680a658f610
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nikic
%global gh_project PHP-Parser
@@ -21,7 +21,7 @@
%global major 4
Name: php-%{gh_owner}-%{pk_project}%{major}
-Version: 4.1.0
+Version: 4.1.1
Release: 1%{?dist}
Summary: A PHP parser written in PHP - version %{major}
@@ -127,14 +127,7 @@ ret=0
for cmdarg in "php %{phpunit}" "php70 %{_bindir}/phpunit6" php71 php72 php73; do
if which $cmdarg; then
set $cmdarg
- VER=$($1 -r 'echo PHP_VERSION_ID;')
- if [ $VER -ge 70300 ]; then
- # ignore failed test, upstream aware of this (by travis)
- # https://github.com/nikic/PHP-Parser/issues/539
- $1 ${2:-%{_bindir}/phpunit7} --filter '^((?!(testParse)).)*$' --verbose || ret=1
- else
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
- fi
+ $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
fi
done
exit $ret
@@ -154,6 +147,9 @@ exit $ret
%changelog
+* Thu Dec 27 2018 Remi Collet <remi@remirepo.net> - 4.1.1-1
+- update to 4.1.1
+
* Wed Oct 10 2018 Remi Collet <remi@remirepo.net> - 4.1.0-1
- update to 4.1.0
- https://github.com/nikic/PHP-Parser/issues/539 - PHP 7.3