summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-07-05 08:42:41 +0200
committerRemi Collet <remi@remirepo.net>2021-07-05 08:42:41 +0200
commitd9b0f54a20bad964952097cd725f0cea65d85576 (patch)
tree5d2c0f5ce2f096d6956df214c67df832f54c48c6
parent279d1237da87a3d5901e907bc9810d10ce5cf31e (diff)
update to 4.11.0
switch to phpunit9
-rw-r--r--php-nikic-php-parser4.spec19
1 files changed, 12 insertions, 7 deletions
diff --git a/php-nikic-php-parser4.spec b/php-nikic-php-parser4.spec
index 084cac0..5aaf346 100644
--- a/php-nikic-php-parser4.spec
+++ b/php-nikic-php-parser4.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 4432ba399e47c66624bc73c8c0f811e5c109576f
+%global gh_commit fe14cf3672a149364fb66dfe11bf6549af899f94
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nikic
%global gh_project PHP-Parser
@@ -21,7 +21,7 @@
%global major 4
Name: php-%{gh_owner}-%{pk_project}%{major}
-Version: 4.10.5
+Version: 4.11.0
Release: 1%{?dist}
Summary: A PHP parser written in PHP - version %{major}
@@ -36,8 +36,8 @@ Patch0: %{name}-rpm.patch
BuildArch: noarch
%if %{with_tests}
# For tests
-# as we use phpunit8
-BuildRequires: php(language) >= 7.2
+# as we use phpunit9
+BuildRequires: php(language) >= 7.3
BuildRequires: php-tokenizer
BuildRequires: php-reflection
BuildRequires: php-ctype
@@ -47,8 +47,8 @@ BuildRequires: php-spl
# From composer.json, "require-dev": {
# "phpunit/phpunit": "^6.5 || ^7.0 || ^8.0 || ^9.0",
# "ircmaxell/php-yacc": "0.0.7"
-%global phpunit %{_bindir}/phpunit8
-BuildRequires: phpunit8
+%global phpunit %{_bindir}/phpunit9
+BuildRequires: phpunit9
# Autoloader
BuildRequires: php-fedora-autoloader-devel
%endif
@@ -128,7 +128,8 @@ else
fi
ret=0
-for cmdarg in "php %{phpunit}" "php72%{_bindir}/phpunit8" php73 php74 php80; do
+# TODO php81
+for cmdarg in "php %{phpunit}" php73 php74 php80; do
if which $cmdarg; then
set $cmdarg
$1 -d auto_prepend_file=%{buildroot}/%{php_home}/%{ns_project}%{major}/autoload.php \
@@ -152,6 +153,10 @@ exit $ret
%changelog
+* Mon Jul 5 2021 Remi Collet <remi@remirepo.net> - 4.11.0-1
+- update to 4.11.0
+- switch to phpunit9
+
* Tue May 4 2021 Remi Collet <remi@remirepo.net> - 4.10.5-1
- update to 4.10.5