summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-08-19 16:03:16 +0200
committerRemi Collet <remi@remirepo.net>2019-08-19 16:03:16 +0200
commit6b79f2fdbdb230a53b6516805b2f02350d761140 (patch)
tree7c3d7dea7161df532f9e604bbf43a18965b24ef0
parent664ef1d3202a25832283cdc7707c877226ceb63c (diff)
v4.2.3
-rw-r--r--composer.json2
-rw-r--r--php-nikic-php-parser4.spec18
2 files changed, 12 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index 9742853..b99182e 100644
--- a/composer.json
+++ b/composer.json
@@ -17,7 +17,7 @@
"ext-tokenizer": "*"
},
"require-dev": {
- "phpunit/phpunit": "^6.5 || ^7.0"
+ "phpunit/phpunit": "^6.5 || ^7.0 || ^8.0"
},
"extra": {
"branch-alias": {
diff --git a/php-nikic-php-parser4.spec b/php-nikic-php-parser4.spec
index 0fbd2c8..f6d26e2 100644
--- a/php-nikic-php-parser4.spec
+++ b/php-nikic-php-parser4.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 1bd73cc04c3843ad8d6b0bfc0956026a151fc420
+%global gh_commit e612609022e935f3d0337c1295176505b41188c8
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nikic
%global gh_project PHP-Parser
@@ -21,7 +21,7 @@
%global major 4
Name: php-%{gh_owner}-%{pk_project}%{major}
-Version: 4.2.2
+Version: 4.2.3
Release: 1%{?dist}
Summary: A PHP parser written in PHP - version %{major}
@@ -43,11 +43,11 @@ BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^6.5 || ^7.0"
+# "phpunit/phpunit": "^6.5 || ^7.0 || ^8.0"
# remirepo:1
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
-%global phpunit %{_bindir}/phpunit7
-BuildRequires: phpunit7
+%global phpunit %{_bindir}/phpunit8
+BuildRequires: phpunit8
# remirepo:4
%else
%global phpunit %{_bindir}/phpunit6
@@ -129,10 +129,10 @@ AUTOLOAD
: Upstream test suite
ret=0
-for cmdarg in "php %{phpunit}" php71 php72 php73 php74; do
+for cmdarg in "php %{phpunit}" "php71 %{_bindir}/phpunit7" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
- $1 ${2:-%{_bindir}/phpunit7} --verbose || ret=1
+ $1 ${2:-%{_bindir}/phpunit8} --verbose || ret=1
fi
done
exit $ret
@@ -152,6 +152,10 @@ exit $ret
%changelog
+* Mon Aug 19 2019 Remi Collet <remi@remirepo.net> - 4.2.3-1
+- update to 4.2.3
+- use phpunit8
+
* Mon May 27 2019 Remi Collet <remi@remirepo.net> - 4.2.2-1
- update to 4.2.2