summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-08-10 06:37:24 +0200
committerRemi Collet <remi@remirepo.net>2020-08-10 06:37:24 +0200
commit309e68f0d3fdb39147b29ff68c8f290e003dba32 (patch)
tree993b80837b95609a9b868fc2450710661385981c
parentd15b5af22a4f7c31ebdf4e9b94dc9249fb761755 (diff)
update to 4.8.0
-rw-r--r--composer.json6
-rw-r--r--php-nikic-php-parser4.spec9
2 files changed, 9 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index 97b6e76..9e22494 100644
--- a/composer.json
+++ b/composer.json
@@ -17,12 +17,12 @@
"ext-tokenizer": "*"
},
"require-dev": {
- "phpunit/phpunit": "^6.5 || ^7.0 || ^8.0",
- "ircmaxell/php-yacc": "0.0.5"
+ "phpunit/phpunit": "^6.5 || ^7.0 || ^8.0 || ^9.0",
+ "ircmaxell/php-yacc": "^0.0.6"
},
"extra": {
"branch-alias": {
- "dev-master": "4.7-dev"
+ "dev-master": "4.8-dev"
}
},
"autoload": {
diff --git a/php-nikic-php-parser4.spec b/php-nikic-php-parser4.spec
index 9026e07..eebe8be 100644
--- a/php-nikic-php-parser4.spec
+++ b/php-nikic-php-parser4.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 21dce06dfbf0365c6a7cc8fdbdc995926c6a9300
+%global gh_commit 8c58eb4cd4f3883f82611abeac2efbc3dbed787e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nikic
%global gh_project PHP-Parser
@@ -21,7 +21,7 @@
%global major 4
Name: php-%{gh_owner}-%{pk_project}%{major}
-Version: 4.7.0
+Version: 4.8.0
Release: 1%{?dist}
Summary: A PHP parser written in PHP - version %{major}
@@ -122,7 +122,7 @@ AUTOLOAD
: Upstream test suite
# ignore test failing on 32-bit (in koji)
ret=0
-for cmdarg in "php %{phpunit}" "php71 %{_bindir}/phpunit7" php72 php73 php74 php80; do
+for cmdarg in "php %{phpunit}" php72 php73 "php74 %{_bindir}/phpunit9" "php80 %{_bindir}/phpunit9"; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit8} \
@@ -147,6 +147,9 @@ exit $ret
%changelog
+* Mon Aug 10 2020 Remi Collet <remi@remirepo.net> - 4.8.0-1
+- update to 4.8.0
+
* Sun Jul 26 2020 Remi Collet <remi@remirepo.net> - 4.7.0-1
- update to 4.7.0