summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-10-28 09:06:10 +0100
committerRemi Collet <remi@remirepo.net>2019-10-28 09:06:10 +0100
commit301ec09d5a9c092b083609f69172da1b364e1c15 (patch)
treec6c4794c9fa5f44fbbffff854cc233610d355a67
parentc87dfe459fc54d1feb935129ec49eeee9f0e43be (diff)
- update to 4.2.5
- sources from git snapshot
-rw-r--r--composer.json3
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-nikic-php-parser4.spec16
3 files changed, 41 insertions, 6 deletions
diff --git a/composer.json b/composer.json
index b99182e..df6f2ea 100644
--- a/composer.json
+++ b/composer.json
@@ -17,7 +17,8 @@
"ext-tokenizer": "*"
},
"require-dev": {
- "phpunit/phpunit": "^6.5 || ^7.0 || ^8.0"
+ "phpunit/phpunit": "^6.5 || ^7.0 || ^8.0",
+ "ircmaxell/php-yacc": "0.0.4"
},
"extra": {
"branch-alias": {
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..7d752c6
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION, Commit=$COMMIT\n"
+
+echo "Cloning..."
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude-vcs $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
+
diff --git a/php-nikic-php-parser4.spec b/php-nikic-php-parser4.spec
index 2d5fdcd..4ea75df 100644
--- a/php-nikic-php-parser4.spec
+++ b/php-nikic-php-parser4.spec
@@ -10,7 +10,7 @@
# For compatibility with SCL
%undefine __brp_mangle_shebangs
-%global gh_commit 97e59c7a16464196a8b9c77c47df68e4a39a45c4
+%global gh_commit b76bbc3c51f22c570648de48e8c2d941ed5e2cf2
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nikic
%global gh_project PHP-Parser
@@ -21,13 +21,14 @@
%global major 4
Name: php-%{gh_owner}-%{pk_project}%{major}
-Version: 4.2.4
+Version: 4.2.5
Release: 1%{?dist}
Summary: A PHP parser written in PHP - version %{major}
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
# Autoloader
Patch0: %{name}-rpm.patch
@@ -43,7 +44,8 @@ BuildRequires: php-json
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "^6.5 || ^7.0 || ^8.0"
+# "phpunit/phpunit": "^6.5 || ^7.0 || ^8.0",
+# "ircmaxell/php-yacc": "0.0.4"
# remirepo:1
%if 0%{?fedora} >= 28 || 0%{?rhel} >= 8
%global phpunit %{_bindir}/phpunit8
@@ -76,7 +78,7 @@ Provides: php-composer(%{gh_owner}/%{pk_project}) = %{version}
%description
-This is a PHP 5.2 to PHP 7.2 parser written in PHP.
+This is a PHP 5.2 to PHP 7.4 parser written in PHP.
Its purpose is to simplify static code analysis and manipulation.
This package provides the library version %{major} and the php-parse%{major} command.
@@ -155,6 +157,10 @@ exit $ret
%changelog
+* Mon Oct 28 2019 Remi Collet <remi@remirepo.net> - 4.2.5-1
+- update to 4.2.5
+- sources from git snapshot
+
* Mon Sep 2 2019 Remi Collet <remi@remirepo.net> - 4.2.4-1
- update to 4.2.4