summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-06-29 07:07:30 +0200
committerRemi Collet <remi@remirepo.net>2017-06-29 07:07:30 +0200
commitfea157511467f2582098bffce4b09e1d6c7f3df2 (patch)
tree1412b32e6434ec45da601cd7d86404bac108aa39
parent33388a6c79fdf3b205668331a703ce80ad483f21 (diff)
v3.0.6
-rw-r--r--.gitignore7
-rw-r--r--php-nikic-php-parser3.spec34
2 files changed, 17 insertions, 24 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..1ab5c4f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-nikic-php-parser3.spec b/php-nikic-php-parser3.spec
index 73a08d3..5683d9b 100644
--- a/php-nikic-php-parser3.spec
+++ b/php-nikic-php-parser3.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 2b9e2f71b722f7c53918ab0c25f7646c2013f17d
+%global gh_commit 0808939f81c1347a3c8a82a5925385a08074b0f1
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nikic
%global gh_project PHP-Parser
@@ -14,7 +14,7 @@
%global php_home %{_datadir}/php
%global with_tests 0%{!?_without_tests:1}
%global major 3
-%global minor 0.5
+%global minor 0.6
%global eolv1 0
%global eolv2 0
@@ -32,7 +32,6 @@ Source: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit
# Autoloader
Patch0: %{name}-rpm.patch
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
@@ -94,8 +93,6 @@ Autoloader: %{php_home}/PhpParser%{major}/autoload.php
%install
-rm -rf %{buildroot}
-
: Library
mkdir -p %{buildroot}%{php_home}
cp -pr lib/PhpParser %{buildroot}%{php_home}/PhpParser%{major}
@@ -116,33 +113,19 @@ php bin/php-parse-test --help
sed -e 's:@BUILDROOT@:%{buildroot}:' -i test/bootstrap.php
: Upstream test suite
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -152,6 +135,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Jun 29 2017 Remi Collet <remi@remirepo.net> - 3.0.6-1
+- Update to 3.0.6
+
* Mon Mar 6 2017 Remi Collet <remi@remirepo.net> - 3.0.5-1
- Update to 3.0.5
- always provide the command, with version suffix