summaryrefslogtreecommitdiffstats
path: root/php-nikic-fast-route.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-nikic-fast-route.spec')
-rw-r--r--php-nikic-fast-route.spec39
1 files changed, 12 insertions, 27 deletions
diff --git a/php-nikic-fast-route.spec b/php-nikic-fast-route.spec
index 8f4aa53..a1e86ea 100644
--- a/php-nikic-fast-route.spec
+++ b/php-nikic-fast-route.spec
@@ -7,7 +7,7 @@
#
# Please preserve changelog entries
-%global gh_commit b5f95749071c82a8e0f58586987627054400cdf6
+%global gh_commit 181d480e08d9476e61381e04a71b34dc0432e812
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nikic
%global gh_project FastRoute
@@ -16,17 +16,15 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{pk_project}
-Version: 1.2.0
+Version: 1.3.0
Release: 1%{?dist}
Summary: Fast implementation of a regular expression based router
-Group: Development/Libraries
License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{name}-%{version}-%{gh_short}.tar.gz
Source1: php-%{gh_owner}-%{pk_project}-tests-autoloader.php
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
@@ -34,8 +32,8 @@ BuildRequires: php(language) >= 5.4
BuildRequires: php-pcre
BuildRequires: php-spl
# From composer.json, "require-dev": {
-# "phpunit/phpunit": "~4.0"
-BuildRequires: php-composer(phpunit/phpunit) >= 4.0
+# "phpunit/phpunit": "^4.8.35|~5.7"
+BuildRequires: php-composer(phpunit/phpunit) >= 4.8.35
%endif
# From composer.json, "require": {
@@ -66,8 +64,6 @@ Autoloader: %{php_home}/%{gh_project}/bootstrap.php
%install
-rm -rf %{buildroot}
-
#: Library
mkdir -p %{buildroot}%{php_home}
cp -pr src %{buildroot}%{php_home}/%{gh_project}
@@ -81,33 +77,19 @@ cp %{SOURCE1} test/bootstrap.php
sed -e "s|BUILDROOT_PATH|%{buildroot}/%{php_home}/%{gh_project}|" -i test/bootstrap.php
: Run upstream test suite
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose
-# remirepo:2
-fi
+for cmd in php php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit --verbose || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc composer.json
@@ -116,6 +98,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Feb 14 2018 Remi Collet <remi@remirepo.net> - 1.3.0-1
+- Update to 1.3.0
+
* Fri Feb 10 2017 Johan Cwiklinski <johan AT x-tnd DOT be> - 1.2.0-1
- Last upstream release