summaryrefslogtreecommitdiffstats
path: root/php-tracy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-tracy.spec')
-rw-r--r--php-tracy.spec30
1 files changed, 13 insertions, 17 deletions
diff --git a/php-tracy.spec b/php-tracy.spec
index a939dbd..66f4984 100644
--- a/php-tracy.spec
+++ b/php-tracy.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit c9fbca15b0a11d904c7783b7aad114182618d8d4
+%global gh_commit e9e93b778a75760a939593384e326fb65f9a0da2
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -16,9 +16,9 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_project}
-Version: 2.4.6
+Version: 2.4.7
%global specrel 1
-Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Tracy: useful PHP debugger
Group: Development/Libraries
@@ -118,21 +118,14 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/autoload.php';
EOF
: Run test suite in sources tree
-# remirepo:11
ret=0
-run=0
-if which php56; then
- php56 %{_bindir}/nette-tester --colors 0 -p php56 -C tests -s || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/nette-tester --colors 0 -p php71 -C tests -d serialize_precision=14 -s || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/nette-tester --colors 0 -p php -C -d serialize_precision=14 tests -s
-# remirepo:2
-fi
+# PHP 7.1/7.2: Fatal error: Unknown: Cannot use output buffering in output buffering display handlers in Unknown on line 0
+# In local build, OK in mock
+for cmd in php php56 php70 php71; do
+ if which $cmd; then
+ $cmd %{_bindir}/nette-tester --colors 0 -p $cmd -C tests -d serialize_precision=14 -s || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
@@ -153,6 +146,9 @@ rm -rf %{buildroot}
%changelog
+* Thu May 11 2017 Remi Collet <remi@remirepo.net> - 2.4.7-1
+- Update to 2.4.7
+
* Mon Jan 30 2017 Remi Collet <remi@fedoraproject.org> - 2.4.6-1
- update to 2.4.6