summaryrefslogtreecommitdiffstats
path: root/php-nette-utils.spec
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2017-03-30 07:39:00 +0200
committerRemi Collet <fedora@famillecollet.com>2017-03-30 07:39:00 +0200
commit19e7e35994bad56d6ae0bddabba392836d66a266 (patch)
tree1aa1492e2ce9a2902d0736e3d078b1f95c00835b /php-nette-utils.spec
parentf6e82db81b9a89f142933747c1ba128465d24eb3 (diff)
switch the specs
Diffstat (limited to 'php-nette-utils.spec')
-rw-r--r--php-nette-utils.spec66
1 files changed, 51 insertions, 15 deletions
diff --git a/php-nette-utils.spec b/php-nette-utils.spec
index 68f3ab1..b49e154 100644
--- a/php-nette-utils.spec
+++ b/php-nette-utils.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit f213ad4d9dfb7221322bd2808e2004b61c8ece8e
+%global gh_commit 714afb64d0da07d0da7178cbf5680008e4b0180b
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -16,7 +16,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-nette-utils
-Version: 2.3.11
+Version: 2.4.4
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Utility Classes
@@ -32,7 +32,7 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-composer(theseer/autoload)
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.1
+BuildRequires: php(language) >= 5.6
BuildRequires: php-iconv
BuildRequires: php-intl
BuildRequires: php-mbstring
@@ -47,13 +47,15 @@ BuildRequires: php-reflection
BuildRequires: php-spl
BuildRequires: php-xml
# From composer.json, "require-dev": {
-# "nette/tester": "~1.0"
+# "nette/tester": "~2.0",
+# "tracy/tracy": "^2.3"
+# ignore tester min version (pass with 1.7), ignore tracy (pass without)
BuildRequires: php-composer(%{gh_owner}/tester)
%endif
# from composer.json, "require": {
-# "php": ">=5.3.1"
-Requires: php(language) >= 5.3.1
+# "php": ">=5.6.0"
+Requires: php(language) >= 5.6
# from composer.json, "suggest": {
# "ext-iconv": "to use Strings::webalize() and toAscii()",
# "ext-json": "to use Nette\\Utils\\Json",
@@ -61,13 +63,22 @@ Requires: php(language) >= 5.3.1
# "ext-mbstring": "to use Strings::lower() etc...",
# "ext-xml": "to use Strings::length() etc. when mbstring is not available",
# "ext-gd": "to use Image"
+%if 0%{?fedora} > 21
+Recommends: php-iconv
+Recommends: php-json
+Recommends: php-intl
+Recommends: php-mbstring
+Recommends: php-xml
+Recommends: php-gd
+%else
Requires: php-iconv
Requires: php-json
Requires: php-intl
Requires: php-mbstring
Requires: php-xml
Requires: php-gd
-# from phpcompatinfo report for version 2.3.6 (mcrypt is optional, openssl prefered)
+%endif
+# from phpcompatinfo report for version 2.4.0 (mcrypt is optional, openssl prefered)
Requires: php-date
Requires: php-fileinfo
Requires: php-openssl
@@ -104,17 +115,14 @@ cp -pr src/* %{buildroot}%{php_home}/%{ns_vendor}/
%if %{with_tests}
: Ignore failed tests under investigation
rm tests/Utils/Image.alpha1.phpt
+rm tests/Utils/Image.alpha2.phpt
+rm tests/Utils/Image.resize.phpt
rm tests/Utils/Json.decode\(\).phpt
rm tests/Utils/Image.drawing.phpt
rm tests/Utils/Image.place.phpt
-: Generate configuration
-cat /etc/php.ini /etc/php.d/*ini >php.ini
export LANG=fr_FR.utf8
-: For PHP 5.3.3 on RHEL-6
-sed -e 's/50303/99999/' -i tests/Utils/Object.magicMethod.errors.phpt
-
: Generate autoloader
mkdir vendor
cat << 'EOF' | tee vendor/autoload.php
@@ -124,7 +132,22 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/Utils/autoload.php';
EOF
: Run test suite in sources tree
-nette-tester --colors 0 -p php -c ./php.ini tests -s
+# remirepo:11
+ret=0
+run=0
+if which php56; then
+ php56 %{_bindir}/nette-tester --colors 0 -p php56 -C tests -s || ret=1
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/nette-tester --colors 0 -p php71 -C tests -s || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/nette-tester --colors 0 -p php -C tests -s
+# remirepo:2
+fi
+exit $ret
%else
: Test suite disabled
%endif
@@ -146,8 +169,21 @@ rm -rf %{buildroot}
%changelog
-* Wed Dec 21 2016 Remi Collet <remi@fedoraproject.org> - 2.3.11-1
-- update to 2.3.11
+* Mon Jan 16 2017 Remi Collet <remi@fedoraproject.org> - 2.4.4-1
+- update to 2.4.4
+
+* Wed Jan 11 2017 Remi Collet <remi@fedoraproject.org> - 2.4.3-1
+- update to 2.4.3
+
+* Wed Dec 21 2016 Remi Collet <remi@fedoraproject.org> - 2.4.2-1
+- update to 2.4.2
+
+* Fri Sep 30 2016 Remi Collet <remi@fedoraproject.org> - 2.4.1-1
+- update to 2.4.1
+
+* Tue Aug 2 2016 Remi Collet <remi@fedoraproject.org> - 2.4.0-1
+- update to 2.4.0
+- raise dependency on PHP >= 5.6
* Mon Jun 20 2016 Remi Collet <remi@fedoraproject.org> - 2.3.10-1
- update to 2.3.10