summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-05-11 19:57:38 +0200
committerRemi Collet <remi@remirepo.net>2017-05-11 19:57:38 +0200
commit55409f8bcaf49ac1a0292ba995ed4131fe632942 (patch)
treeda3828c624de82f0f03a20a3412ad73776c4b43c
parent1e77a1d4391a87b855710a363f0323e51bd206e7 (diff)
v2.4.6
-rw-r--r--composer.json3
-rw-r--r--php-nette-utils.spec29
2 files changed, 14 insertions, 18 deletions
diff --git a/composer.json b/composer.json
index 600e404..b33767a 100644
--- a/composer.json
+++ b/composer.json
@@ -26,8 +26,7 @@
"ext-intl": "for script transliteration in Strings::webalize() and toAscii()",
"ext-mbstring": "to use Strings::lower() etc...",
"ext-xml": "to use Strings::length() etc. when mbstring is not available",
- "ext-gd": "to use Image",
- "https://nette.org/donate": "\u001b[1;37;42m Please consider supporting Nette via a donation \u001b[0m"
+ "ext-gd": "to use Image"
},
"conflict": {
"nette/nette": "<2.2"
diff --git a/php-nette-utils.spec b/php-nette-utils.spec
index a0ea3f0..b8acdc1 100644
--- a/php-nette-utils.spec
+++ b/php-nette-utils.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 28ad4e2a6dcf143c23bde969a825f10a5d513602
+%global gh_commit 266160aec0d99516e0ea510de1dfa24a0dc1e76e
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -16,7 +16,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-nette-utils
-Version: 2.4.5
+Version: 2.4.6
%global specrel 1
Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Utility Classes
@@ -133,21 +133,15 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/Utils/autoload.php';
EOF
: Run test suite in sources tree
-# remirepo:11
ret=0
-run=0
-if which php56; then
- php56 %{_bindir}/nette-tester --colors 0 -p php56 -C tests -s || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/nette-tester --colors 0 -p php71 -C tests -s || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/nette-tester --colors 0 -p php -C tests -s
-# remirepo:2
-fi
+# PHP 7.2
+# -- FAILED: Nette\Utils\ArrayHash basic usage. | tests/Utils/ArrayHash.phpt
+# Failed: [0, 1] should be ['0', '1']
+for cmd in php php56 php70 php71; do
+ if which $cmd; then
+ $cmd %{_bindir}/nette-tester --colors 0 -p $cmd -C tests -s || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
@@ -170,6 +164,9 @@ rm -rf %{buildroot}
%changelog
+* Thu May 11 2017 Remi Collet <remi@remirepo.net> - 2.4.6-1
+- Update to 2.4.6
+
* Thu Mar 30 2017 Remi Collet <remi@remirepo.net> - 2.4.5-1
- Update to 2.4.5