summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-02 16:24:18 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-02 16:24:18 +0200
commit2b27a1ad70f60e66667a321fbfde789dcb874e97 (patch)
tree5edd41d2a142a86111ed1997d1a250ef4bc9b8b8
parent6bf4db162a6ff6cf90d818db7fe7538bec3d2d4f (diff)
php-nette-utils: 2.3.9
-rw-r--r--composer.json35
-rw-r--r--php-nette-utils.spec8
2 files changed, 41 insertions, 2 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..49f3cc7
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,35 @@
+{
+ "name": "nette/utils",
+ "description": "Nette Utility Classes",
+ "homepage": "https://nette.org",
+ "license": ["BSD-3-Clause", "GPL-2.0", "GPL-3.0"],
+ "authors": [
+ {
+ "name": "David Grudl",
+ "homepage": "https://davidgrudl.com"
+ },
+ {
+ "name": "Nette Community",
+ "homepage": "https://nette.org/contributors"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.1"
+ },
+ "require-dev": {
+ "nette/tester": "~1.0"
+ },
+ "suggest": {
+ "ext-iconv": "to use Strings::webalize() and toAscii()",
+ "ext-intl": "for script transliteration in Strings::webalize() and toAscii()",
+ "ext-mbstring": "to use Strings::lower() etc...",
+ "ext-gd": "to use Image"
+ },
+ "conflict": {
+ "nette/nette": "<2.2"
+ },
+ "autoload": {
+ "classmap": ["src/"]
+ },
+ "minimum-stability": "dev"
+}
diff --git a/php-nette-utils.spec b/php-nette-utils.spec
index 79f296e..232b8c9 100644
--- a/php-nette-utils.spec
+++ b/php-nette-utils.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 34ca4cd67bb768199aae2879eb8ad0ab016f2d8a
+%global gh_commit f6586f827292bd35c8593df943437f2247ba5337
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -16,7 +16,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-nette-utils
-Version: 2.3.8
+Version: 2.3.9
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Utility Classes
@@ -29,6 +29,7 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
Source1: makesrc.sh
# https://github.com/nette/utils/pull/91
+# And https://github.com/nette/utils/issues/112
Patch0: %{name}-pr91.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
@@ -162,6 +163,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Jun 2 2016 Remi Collet <remi@fedoraproject.org> - 2.3.9-1
+- update to 2.3.9
+
* Sat Apr 2 2016 Remi Collet <remi@fedoraproject.org> - 2.3.8-1
- update to 2.3.8
- run test suite with both php 5 and 7 when available