summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-03-20 07:50:37 +0100
committerRemi Collet <fedora@famillecollet.com>2016-03-20 07:50:37 +0100
commitfc3b731b8264af0be3c547f642744a4b1dca3c33 (patch)
treeccbb1050c0a75955b1b641db6fbb9d90bb1479b6
parentaae51b3dd0e65c86a38e76f0e75b1c8bd3645b7d (diff)
php-nette-tester: 1.7.1
-rwxr-xr-xmakesrc.sh28
-rw-r--r--php-nette-tester.spec18
2 files changed, 42 insertions, 4 deletions
diff --git a/makesrc.sh b/makesrc.sh
new file mode 100755
index 0000000..e9a1ec5
--- /dev/null
+++ b/makesrc.sh
@@ -0,0 +1,28 @@
+#!/bin/bash
+
+NAME=$(basename $PWD)
+OWNER=$(sed -n '/^%global gh_owner/{s/.* //;p}' $NAME.spec)
+PROJECT=$(sed -n '/^%global gh_project/{s/.* //;p}' $NAME.spec)
+VERSION=$(sed -n '/^Version:/{s/.* //;p}' $NAME.spec)
+COMMIT=$(sed -n '/^%global gh_commit/{s/.* //;p}' $NAME.spec)
+SHORT=${COMMIT:0:7}
+
+echo -e "\nCreate git snapshot\nName=$NAME, Owner=$OWNER, Project=$PROJECT, Version=$VERSION\n"
+
+echo "Cloning..."
+rm -rf $PROJECT-$COMMIT
+git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
+
+echo "Getting commit..."
+pushd $PROJECT-$COMMIT
+git checkout $COMMIT
+cp composer.json ../composer-$VERSION.json
+popd
+
+echo "Archiving..."
+tar czf $NAME-$VERSION-$SHORT.tgz --exclude .git $PROJECT-$COMMIT
+
+echo "Cleaning..."
+rm -rf $PROJECT-$COMMIT
+
+echo "Done."
diff --git a/php-nette-tester.spec b/php-nette-tester.spec
index 456a596..1983cd6 100644
--- a/php-nette-tester.spec
+++ b/php-nette-tester.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit efbc31ff4ee0bef28da712a726316e8b0b5bf262
+%global gh_commit d97534578e8cf66eabe081e7d5eaa4dd527ab0c8
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -15,7 +15,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-nette-tester
-Version: 1.7.0
+Version: 1.7.1
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: An easy-to-use PHP unit testing framework
@@ -23,7 +23,8 @@ Summary: An easy-to-use PHP unit testing framework
Group: Development/Libraries
License: BSD or GPLv2 or GPLv3
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source0: %{name}-%{version}-%{gh_short}.tgz
+Source1: makesrc.sh
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -41,6 +42,9 @@ BuildRequires: php-reflection
BuildRequires: php-simplexml
BuildRequires: php-spl
BuildRequires: php-tokenizer
+%if 0%{?fedora} >= 24
+BuildRequires: glibc-langpack-fr
+%endif
%endif
# from composer.json
@@ -123,6 +127,12 @@ rm -rf %{buildroot}
%changelog
+* Sun Mar 20 2016 Remi Collet <remi@fedoraproject.org> - 1.7.1-1
+- update to 1.7.1
+- sources from git snapshot
+ open https://github.com/nette/tester/issues/297
+- add BR glibc-langpack-fr on F24+
+
* Fri Feb 12 2016 Remi Collet <remi@fedoraproject.org> - 1.7.0-1
- update to 1.7.0
- run test suite with both PHP 5 and 7 when available
@@ -131,4 +141,4 @@ rm -rf %{buildroot}
- update to 1.6.1
* Tue Oct 20 2015 Remi Collet <remi@fedoraproject.org> - 1.6.0-1
-- initial package \ No newline at end of file
+- initial package