summaryrefslogtreecommitdiffstats
path: root/php-nette-security.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-nette-security.spec')
-rw-r--r--php-nette-security.spec60
1 files changed, 39 insertions, 21 deletions
diff --git a/php-nette-security.spec b/php-nette-security.spec
index 85aa50f..66903da 100644
--- a/php-nette-security.spec
+++ b/php-nette-security.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 779254a5484a106344a81c8cb9ce2b8570e38f34
+%global gh_commit e547c81b36bae6cb5a6ba0c498314940f5d428ed
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.3.2
+Version: 2.4.1
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Security: Access Control Component
@@ -33,25 +33,27 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-composer(theseer/autoload)
%if %{with_tests}
-BuildRequires: php(language) >= 5.3.1
+BuildRequires: php(language) >= 5.6
BuildRequires: php-pcre
BuildRequires: php-session
BuildRequires: php-spl
-BuildRequires: php-composer(%{gh_owner}/utils) >= 2.2
+BuildRequires: php-composer(%{gh_owner}/utils) >= 2.4
# From composer.json, "require-dev": {
-# "nette/di": "~2.3",
-# "nette/http": "~2.3",
-# "nette/tester": "~1.4"
-BuildRequires: php-composer(%{gh_owner}/di) >= 2.3
-BuildRequires: php-composer(%{gh_owner}/http) >= 2.3
-BuildRequires: php-composer(%{gh_owner}/tester) >= 1.4
+# "nette/di": "~2.4",
+# "nette/http": "~2.4",
+# "nette/tester": "~2.0",
+# "tracy/tracy": "^2.4"
+BuildRequires: php-composer(%{gh_owner}/di) >= 2.4
+BuildRequires: php-composer(%{gh_owner}/http) >= 2.4
+BuildRequires: php-composer(%{gh_owner}/tester) >= 2.0
+BuildRequires: php-composer(tracy/tracy) >= 2.4
%endif
# from composer.json, "require": {
-# "php": ">=5.3.1"
-# "nette/utils": "~2.2"
-Requires: php(language) >= 5.3.1
-Requires: php-composer(%{gh_owner}/utils) >= 2.2
+# "php": ">=5.6.0",
+# "nette/utils": "~2.4"
+Requires: php(language) >= 5.6
+Requires: php-composer(%{gh_owner}/utils) >= 2.4
Requires: php-composer(%{gh_owner}/utils) < 3
# from phpcompatinfo report for version 2.3.1
Requires: php-pcre
@@ -95,8 +97,6 @@ cp -pr src/* %{buildroot}%{php_home}/%{ns_vendor}/
%check
%if %{with_tests}
-: Generate configuration
-cat /etc/php.ini /etc/php.d/*ini >php.ini
export LANG=fr_FR.utf8
: Generate autoloader
@@ -110,12 +110,22 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Run test suite in sources tree
-nette-tester --colors 0 -p php -c ./php.ini tests -s
-
-if which php70; then
- cat /etc/opt/remi/php70/php.ini /etc/opt/remi/php70/php.d/*ini >php.ini
- php70 %{_bindir}/nette-tester --colors 0 -p php70 -c ./php.ini tests -s
+# remirepo:11
+ret=0
+run=0
+if which php56; then
+ php56 %{_bindir}/nette-tester --colors 0 -p php56 -C tests -s || ret=1
+ run=1
+fi
+if which php71; then
+ php71 %{_bindir}/nette-tester --colors 0 -p php71 -C tests -s || ret=1
+ run=1
+fi
+if [ $run -eq 0 ]; then
+%{_bindir}/nette-tester --colors 0 -p php -C tests -s
+# remirepo:2
fi
+exit $ret
%else
: Test suite disabled
%endif
@@ -136,6 +146,14 @@ rm -rf %{buildroot}
%changelog
+* Tue Dec 20 2016 Remi Collet <remi@fedoraproject.org> - 2.4.1-1
+- update to 2.4.1
+
+* Thu Aug 4 2016 Remi Collet <remi@fedoraproject.org> - 2.4.0-1
+- update to 2.4.0
+- raise dependency on PHP >= 5.6
+- raise dependency on nette/utils >= 2.4
+
* Mon Jun 20 2016 Remi Collet <remi@fedoraproject.org> - 2.3.2-1
- update to 2.3.2