summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-nette-security.spec36
1 files changed, 12 insertions, 24 deletions
diff --git a/php-nette-security.spec b/php-nette-security.spec
index 66903da..28555e5 100644
--- a/php-nette-security.spec
+++ b/php-nette-security.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit e547c81b36bae6cb5a6ba0c498314940f5d428ed
+%global gh_commit 8a3051f9b16d4d7bfa18b6b0ff6f9f6f418f9801
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,9 +17,9 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.1
+Version: 2.4.2
%global specrel 1
-Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Security: Access Control Component
Group: Development/Libraries
@@ -29,7 +29,6 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
# pull a git snapshot to get test sutie
Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-composer(theseer/autoload)
%if %{with_tests}
@@ -90,7 +89,6 @@ EOF
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
cp -pr src/* %{buildroot}%{php_home}/%{ns_vendor}/
@@ -110,33 +108,20 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Run test suite in sources tree
-# remirepo:11
ret=0
-run=0
-if which php56; then
- php56 %{_bindir}/nette-tester --colors 0 -p php56 -C tests -s || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/nette-tester --colors 0 -p php71 -C tests -s || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/nette-tester --colors 0 -p php -C tests -s
-# remirepo:2
-fi
+# PHP 7.2: https://github.com/nette/http/issues/128 (each)
+for cmd in php php56 php70 php71; do
+ if which $cmd; then
+ $cmd %{_bindir}/nette-tester --colors 0 -p $cmd -C tests -d serialize_precision=14 -s || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license license.md
%doc readme.md contributing.md
@@ -146,6 +131,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Aug 6 2017 Remi Collet <remi@remirepo.net> - 2.4.2-1
+- Update to 2.4.2
+
* Tue Dec 20 2016 Remi Collet <remi@fedoraproject.org> - 2.4.1-1
- update to 2.4.1