summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-20 12:16:33 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-20 12:16:33 +0200
commitc72f381b272272f28e513da51e94ddc3e2677d63 (patch)
tree84d238948f2d2d93f10dae35d3e2139bc6b679ea
parentd71c98439bffc0dfc17b6d6e195b2570fb2ec5e3 (diff)
php-nette-security: 2.3.2
-rw-r--r--composer.json32
-rw-r--r--php-nette-security.spec14
2 files changed, 43 insertions, 3 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..c95cdb1
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,32 @@
+{
+ "name": "nette/security",
+ "description": "Nette Security: Access Control Component",
+ "homepage": "https://nette.org",
+ "license": ["BSD-3-Clause", "GPL-2.0", "GPL-3.0"],
+ "authors": [
+ {
+ "name": "David Grudl",
+ "homepage": "https://davidgrudl.com"
+ },
+ {
+ "name": "Nette Community",
+ "homepage": "https://nette.org/contributors"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.1",
+ "nette/utils": "~2.2"
+ },
+ "require-dev": {
+ "nette/di": "~2.3",
+ "nette/http": "~2.3",
+ "nette/tester": "~1.4"
+ },
+ "conflict": {
+ "nette/nette": "<2.2"
+ },
+ "autoload": {
+ "classmap": ["src/"]
+ },
+ "minimum-stability": "dev"
+}
diff --git a/php-nette-security.spec b/php-nette-security.spec
index 0e06a98..59f8cdf 100644
--- a/php-nette-security.spec
+++ b/php-nette-security.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 744264a42b506d63009d7e3853ed72b04c99e964
+%global gh_commit 779254a5484a106344a81c8cb9ce2b8570e38f34
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.3.1
+Version: 2.3.2
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Security: Access Control Component
@@ -111,6 +111,11 @@ EOF
: Run test suite in sources tree
nette-tester --colors 0 -p php -c ./php.ini tests -s
+
+if which php70; then
+ cat /etc/opt/remi/php70/php.ini /etc/opt/remi/php70/php.d/*ini >php.ini
+ php70 %{_bindir}/nette-tester --colors 0 -p php70 -c ./php.ini tests -s
+fi
%else
: Test suite disabled
%endif
@@ -131,5 +136,8 @@ rm -rf %{buildroot}
%changelog
+* Mon Jun 20 2016 Remi Collet <remi@fedoraproject.org> - 2.3.2-1
+- update to 2.3.2
+
* Fri Oct 30 2015 Remi Collet <remi@fedoraproject.org> - 2.3.1-1
-- initial package \ No newline at end of file
+- initial package