summaryrefslogtreecommitdiffstats
path: root/php-nette-robot-loader.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-nette-robot-loader.spec')
-rw-r--r--php-nette-robot-loader.spec40
1 files changed, 11 insertions, 29 deletions
diff --git a/php-nette-robot-loader.spec b/php-nette-robot-loader.spec
index bcfa922..ee38961 100644
--- a/php-nette-robot-loader.spec
+++ b/php-nette-robot-loader.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit f23f8885624b249d5ec7bb525b9d6b007ab00293
+%global gh_commit 73149b9724ca24c1215b5d53860b77f113bcf063
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,9 +17,9 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.2
+Version: 2.4.3
%global specrel 1
-Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette RobotLoader: comfortable autoloading
Group: Development/Libraries
@@ -29,10 +29,6 @@ Source0: %{name}-%{version}-%{gh_short}.tgz
# pull a git snapshot to get test sutie
Source1: makesrc.sh
-# Ensure TEMP_DIR exists
-Patch0: %{name}-rpm.patch
-
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: php-composer(theseer/autoload)
%if %{with_tests}
@@ -88,8 +84,6 @@ To use this library, you just have to add, in your project:
%prep
%setup -q -n %{gh_project}-%{gh_commit}
-%patch0 -p0 -b .rpm
-
%build
: Generate a classmap autoloader
@@ -104,7 +98,6 @@ EOF
%install
-rm -rf %{buildroot}
mkdir -p %{buildroot}%{php_home}/%{ns_vendor}
cp -pr src/* %{buildroot}%{php_home}/%{ns_vendor}/
@@ -122,33 +115,19 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Run test suite in sources tree
-# remirepo:11
ret=0
-run=0
-if which php56; then
- php56 %{_bindir}/nette-tester --colors 0 -p php56 -C tests -s || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/nette-tester --colors 0 -p php71 -C tests -s || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/nette-tester --colors 0 -p php -C tests -s
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/nette-tester --colors 0 -p $cmd -C tests -s || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license license.md
%doc readme.md contributing.md
@@ -157,6 +136,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Aug 6 2017 Remi Collet <remi@remirepo.net> - 2.4.3-1
+- Update to 2.4.3
+
* Wed Jan 4 2017 Remi Collet <remi@fedoraproject.org> - 2.4.2-1
- update to 2.4.2