summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-14 07:05:30 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-14 07:05:30 +0200
commitdb20676d57965c5f18744852d4c3e2fc69375336 (patch)
treefbbeb217940ec011c5672a2a6916651445f6dcb8
parent673d8cf6f852885cbb32e02254ae6a7be734cf6f (diff)
php-nette-mail: 2.3.5
-rw-r--r--composer.json35
-rw-r--r--php-nette-mail.spec17
2 files changed, 48 insertions, 4 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..a138339
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,35 @@
+{
+ "name": "nette/mail",
+ "description": "Nette Mail: Sending E-mails",
+ "homepage": "https://nette.org",
+ "license": ["BSD-3-Clause", "GPL-2.0", "GPL-3.0"],
+ "authors": [
+ {
+ "name": "David Grudl",
+ "homepage": "https://davidgrudl.com"
+ },
+ {
+ "name": "Nette Community",
+ "homepage": "https://nette.org/contributors"
+ }
+ ],
+ "require": {
+ "php": ">=5.3.1",
+ "ext-iconv": "*",
+ "nette/utils": "~2.2"
+ },
+ "require-dev": {
+ "nette/di": "~2.3",
+ "nette/tester": "~1.3"
+ },
+ "conflict": {
+ "nette/nette": "<2.2"
+ },
+ "suggest": {
+ "ext-fileinfo": "to detect type of attached files"
+ },
+ "autoload": {
+ "classmap": ["src/"]
+ },
+ "minimum-stability": "dev"
+}
diff --git a/php-nette-mail.spec b/php-nette-mail.spec
index 650c619..8b0e391 100644
--- a/php-nette-mail.spec
+++ b/php-nette-mail.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 3b8ba96407029d94d83177086bcb5e1fe0046929
+%global gh_commit 44491710d30db970e731c3908c491d061a0e22df
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,7 +17,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.3.4
+Version: 2.3.5
%global specrel 1
Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Mail: Sending E-mails
@@ -106,7 +106,13 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Run test suite in sources tree
-nette-tester --colors 0 -p php -c ./php.ini tests -s
+%{_bindir}/nette-tester --colors 0 -p php -c ./php.ini tests -s
+
+# remirepo:4
+if which php70; then
+ cat /etc/opt/remi/php70/php.ini /etc/opt/remi/php70/php.d/*ini >php.ini
+ php70 %{_bindir}/nette-tester --colors 0 -p php70 -c ./php.ini tests -s
+fi
%else
: Test suite disabled
%endif
@@ -127,8 +133,11 @@ rm -rf %{buildroot}
%changelog
+* Thu Apr 14 2016 Remi Collet <remi@fedoraproject.org> - 2.3.5-1
+- update to 2.3.5
+
* Mon Nov 30 2015 Remi Collet <remi@fedoraproject.org> - 2.3.4-1
- update to 2.3.4
* Fri Oct 30 2015 Remi Collet <remi@fedoraproject.org> - 2.3.3-1
-- initial package \ No newline at end of file
+- initial package