summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-08-06 09:55:04 +0200
committerRemi Collet <remi@remirepo.net>2017-08-06 09:55:04 +0200
commit5e2b864c1292225408060558c443d9644c4b26a7 (patch)
tree3b42293c6b636e983ce4c9a68e94d7d6c6135bac
parent1742fa79c9bd8be6823dd6dcc73e59acdd7ed6f6 (diff)
-rw-r--r--php-nette-mail.spec28
1 files changed, 11 insertions, 17 deletions
diff --git a/php-nette-mail.spec b/php-nette-mail.spec
index b3f4830..ca63eb7 100644
--- a/php-nette-mail.spec
+++ b/php-nette-mail.spec
@@ -6,7 +6,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 2bb0333200dbec22b0c1868d907e3e451b555665
+%global gh_commit 2511b0cfa7c181c5fe333838152e308605594c53
#global gh_date 20150728
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nette
@@ -17,9 +17,9 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-%{gh_owner}-%{gh_project}
-Version: 2.4.2
+Version: 2.4.3
%global specrel 1
-Release: %{?gh_date:0.%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
+Release: %{?gh_date:1%{specrel}.%{?prever}%{!?prever:%{gh_date}git%{gh_short}}}%{!?gh_date:%{specrel}}%{?dist}
Summary: Nette Mail: Sending E-mails
Group: Development/Libraries
@@ -106,21 +106,12 @@ require_once '%{buildroot}%{php_home}/%{ns_vendor}/%{ns_project}/autoload.php';
EOF
: Run test suite in sources tree
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/nette-tester --colors 0 -p php56 -C tests -s
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/nette-tester --colors 0 -p php71 -C tests -s
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/nette-tester --colors 0 -p php -C tests -s
-# remirepo:2
-fi
+for cmd in php php56 php70 php71 php72; do
+ if which $cmd; then
+ $cmd %{_bindir}/nette-tester --colors 0 -p $cmd -C tests -d serialize_precision=14 -s || ret=1
+ fi
+done
exit $ret
%else
: Test suite disabled
@@ -142,6 +133,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Aug 6 2017 Remi Collet <remi@remirepo.net> - 2.4.3-1
+- Update to 2.4.3
+
* Sun Feb 26 2017 Remi Collet <remi@fedoraproject.org> - 2.4.2-1
- update to 2.4.2